1. 程式人生 > >【Dijkstra算法】Roadblocks

【Dijkstra算法】Roadblocks

int 長度 print describe lang line plm same paths

Time Limit: 2000MS Memory Limit: 65536K

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R
Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

Output

Line 1: The length of the second shortest path between node 1 and node N

Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450) OJ:POJ 題目大意 某街區共有R條道路、N個路口。道路可以雙向通行。問1號路口到N號路口的次短路長度是多少?次短路指的是比最短路長度長的次短的路徑。同一條邊可以經過多次。(摘自《挑戰程序設計 第二版》) 分析 用Dijkstra算法來求,單源最短路問題,到某個頂點v的次短路要麽是①到其他某個頂點u的最短路再加上u->v的邊,要麽是到u的次短路再加上u->v的邊。 參考代碼
#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>

using namespace std;

const int MAX_V=5001;
const int INF=1e9;

struct edge{
int to;//邊的出點
int cost;//權值
};

vector<edge> G[MAX_V];//鄰接表

typedef pair<int,int> P;//first是源點到該點的距離,second是當前頂點

int dist1[MAX_V];//存最短距離
int dist2[MAX_V];//存次短距離
int N,R;//N個路口,R條道路
void dijkstra();
int main()
{

    int s,w,t;
    edge e;
    scanf("%d%d",&N,&R);
    for(int i=0;i<R;i++){
    scanf("%d%d%d",&s,&t,&w);
    e.to=t-1;
    e.cost=w;
    G[s-1].push_back(e);
    e.to=s-1;
    G[t-1].push_back(e);
    }
    dijkstra();
    printf("%d\n",dist2[N-1]);
    return 0;
}

void dijkstra(){
    priority_queue <P,vector<P>,greater<P> >que;
    fill(dist1,dist1+N,INF);
    fill(dist2,dist2+N,INF);
    dist1[0]=0;
    que.push(P(0,0));
    while(!que.empty()){
        P p=que.top();
        que.pop();
        int v=p.second;//新的源點
        int d=p.first;
        /*如果舊源點到新源點的距離比舊源點到新源點的距離大,
        那麽不用執行下面的代碼去更新新源點到其他各點的dist1,dist2
        因為它算出來的距離肯定比以前算出來的大。
        */
        if(d>dist2[v])
            continue;
        for(int i=0;i<G[v].size();i++){
            edge& e=G[v][i];
            int d2=d+e.cost;
            if(dist1[e.to]>d2){///最短距離
                swap(d2,dist1[e.to]);
                que.push(P(dist1[e.to], e.to));
            }
            /*
            d2大於源點到e.to的最短距離,小於以前計算的次短距離則更新
            */
            if(d2>dist1[e.to]&&d2<dist2[e.to]){///次短距離
                dist2[e.to]=d2;
                que.push(P(dist2[e.to],e.to));
            }
        }

    }

}

參考自http://blog.csdn.net/gemire/article/details/20832199

【Dijkstra算法】Roadblocks