1. 程式人生 > >B - Radar Installation poj 1328【貪心】

B - Radar Installation poj 1328【貪心】

mini col write use 區間 sea sting sts repr

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
技術分享
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1
題意:給出坐標點的總數n和雷達輻射半徑R,再給你n個坐標,問在X軸上最少需要多少個雷達可以覆蓋所有坐標點。
思路:待更新。。。。

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define N 1100
struct node {
    double x1,x2;
}c[N];

double cmp(struct node a,struct node b)
{
    if(a.x1 > b.x1 )
        return a.x1 < b.x1 ;
}
int main()
{
    int i,j,n,R,ans,t=0;
    double x,y,coords;
    while(scanf("%d%d",&n,&R),n!=0&&R!=0)//不能用(n+R)作為循環條件,因為3 -3這種情況不滿足 
    {
        ans = 1;
        if(R <= 0)//先判斷半徑是否滿足條件 
            ans = -1;

        for(i = 1; i <= n; i ++)
        {
            scanf("%lf%lf",&x,&y);//坐標是實數 
            if(fabs(y) > R)//縱坐標大於半徑時  不滿足條件 
            {
                ans = -1;
            }
            else
            {
                coords = sqrt(R*R-y*y);
                c[i].x1 = x - coords;//計算與x軸相交的左右端點 
                c[i].x2 = x + coords;
            }
        }
        if( ans == -1)
        {
            printf("Case %d: %d\n",++t,ans);
            continue;
        }
        sort(c+1,c+1+n,cmp);//結構體排序 
        coords = c[1].x2 ;//初始化為最左坐標的右端點 
        
        for(i = 2; i <= n; i ++)
        {
            if(c[i].x1 > coords)//如果下一個坐標的左端點大於上一個坐標右端點 說明兩者沒有公共區間 
            {
                ans ++;
                coords = c[i].x2 ;
            }
            else if(c[i].x2 < coords)//如果下一個坐標的右端點小於上一個坐標的右端點,說明存在公共區間 
                coords = c[i].x2 ;
        }
        printf("Case %d: %d\n",++t,ans);
    }
    return 0;
}

B - Radar Installation poj 1328【貪心】