1. 程式人生 > >POJ 2318 TOYS (計算幾何)叉積的運用

POJ 2318 TOYS (計算幾何)叉積的運用

line sync ted all names pri char ems sizeof

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John‘s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.
技術分享


For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box. 題意:已知一個左上角頂點(x1,y1),右下角頂點(x2,y2)的方形區域,區域被n條線分成n+1個區域,題目保證線從左到右給出且不相交。 告訴你m個點,點不會在線上出現,求各個區域內的點的數量。 叉積的初步運用,數據也很松,這道題目只需要將點與線依次判斷叉積即可。 如何判斷點s(x0,y0)在s1(x1,y1),s2(x2,y2)的那一側? 先要得到向量p1=s1-s0=(x1-x0,y1-y0),p2=s2-s0=(x2-x0,y2-y0),這裏再用叉積的公式即可,結果依據右手定則。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<stack>
#include<map>
#include<vector>
#include<set>
using namespace std;
const int MAX=5e3+10;
const double eps=1e-4;
const double mod=1e9+7;
#define INF 0x7fffffff
#define ll long long
#define edl putchar(‘\n‘)
#define useit  ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);
#define FOR(i,a,b) for(int i=a;i<=b;i++)
#define ROF(i,a,b) for(int i=a;i>=b;i--)
#define mst(a) memset(a,0,sizeof(a))
#define mstn(a,n) memset(a,n,sizeof(a))
struct point{double x,y;}a[MAX][3],b;
//bool cmp(const num &x, const num &y){return x.v>y.v;}
double cross(point a,point b){return (a.x*b.y-a.y*b.x);}
double dot(point a,point b){return (a.x*b.x+a.y*b.y);}
double cro(point a,point b,point c){return (a.x-c.x)*(b.y-c.y)-(b.x-c.x)*(a.y-c.y);}
int main()
{
    double x1,y1,x2,y2;
    int n,m,cas=0;
    int c[MAX];
    while(scanf("%d",&n)&&n)
    {
        scanf("%d%lf%lf%lf%lf",&m,&x1,&y1,&x2,&y2);
        if(cas) edl;
        mst(c);
        FOR(i,1,n)cin>>a[i][1].x>>a[i][2].x,a[i][1].y=y1,a[i][2].y=y2;
        //a[0][1].x=x1,a[0][1].y=y1,a[0][2].x=x1,a[0][2].y=y2;
        a[n+1][1].x=x2,a[n+1][1].y=y1,a[n+1][2].x=x2,a[n+1][2].y=y2;
        while(m--)
        {
            cin>>b.x>>b.y;
            FOR(i,1,n+1)
            {
                if(cro(a[i][2],a[i][1],b)>0)
                {
                    c[i-1]++;
                    break;
                }
            }
        }
        FOR(i,0,n)
        cout<<i<<": "<<c[i]<<endl;
        cas++;
    }
    
}

至於第二題,題面幾乎完全相同,不同點有二:一、線的給出不按從左到右,但仍不相交。二、答案要求略有不同

解決線的排序問題很簡單,由於不會相交,只要按線的中點坐標排序即可。

代碼如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<stack>
#include<map>
#include<vector>
#include<set>
using namespace std;
const int MAX=5e3+10;
const double eps=1e-4;
const double mod=1e9+7;
#define INF 0x7fffffff
#define ll long long
#define edl putchar(‘\n‘)
#define useit  ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);
#define FOR(i,a,b) for(int i=a;i<=b;i++)
#define ROF(i,a,b) for(int i=a;i>=b;i--)
#define mst(a) memset(a,0,sizeof(a))
#define mstn(a,n) memset(a,n,sizeof(a))
struct point{double x1,y1,x2,y2,c;}a[MAX],b;
bool cmp(const point &x, const point &y){return x.c<y.c;}
//double cross(point a,point b){return (a.x*b.y-a.y*b.x);}
//double dot(point a,point b){return (a.x*b.x+a.y*b.y);}
double cro(point a,point c){return (a.x2-c.x1)*(a.y1-c.y1)-(a.x1-c.x1)*(a.y2-c.y1);}
int main()
{
    double x1,y1,x2,y2;
    int n,m,cas=0;
    int c[MAX],d[MAX],e[MAX];
    while(scanf("%d",&n)&&n)
    {
        scanf("%d%lf%lf%lf%lf",&m,&x1,&y1,&x2,&y2);
        if(cas) edl;
        mst(c);
        mst(d);
        FOR(i,1,n)cin>>a[i].x1>>a[i].x2,a[i].y1=y1,a[i].y2=y2,a[i].c=a[i].x1+a[i].x2;
        sort(a+1,a+n+1,cmp);
        //a[0][1].x=x1,a[0][1].y=y1,a[0][2].x=x1,a[0][2].y=y2;
        a[n+1].x1=x2,a[n+1].y1=y1,a[n+1].x2=x2,a[n+1].y2=y2;
        while(m--)
        {
            cin>>b.x1>>b.y1;
            FOR(i,1,n+1)
            {
                if(cro(a[i],b)>0)
                {
                    c[i-1]++;
                    break;
                }
            }
        }
        sort(c,c+n+1);
        printf("Box\n");
        int jishu=1;
        FOR(i,0,n)
        {
            if(c[i]!=0)
            {
                if(c[i]==c[i+1])
                jishu++;
                else
                {
                    printf("%d: %d\n",c[i],jishu);
                    jishu=1;
                }
            }
        }
        cas++;
    }        
}

POJ 2318 TOYS (計算幾何)叉積的運用