1. 程式人生 > >HDU 2553 N皇後問題 (DFS_回溯)

HDU 2553 N皇後問題 (DFS_回溯)

class blog -a mono color popu cstring str ==

Problem Description 在N*N的方格棋盤放置了N個皇後,使得它們不相互攻擊(即隨意2個皇後不同意處在同一排,同一列,也不同意處在與棋盤邊框成45角的斜線上。
你的任務是。對於給定的N,求出有多少種合法的放置方法。



?
Input 共同擁有若幹行。每行一個正整數N≤10,表示棋盤和皇後的數量;假設N=0。表示結束。 ?
Output 共同擁有若幹行。每行一個正整數,表示相應輸入行的皇後的不同放置數量。 ?
Sample Input

1
8
5
0


?

Sample Output
1
92
10


?

直接求會超時。打個表就不會了。。。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int a[20],ans,n,f[20];

void dfs(int cnt)
{
	if(cnt==n) {
		ans++;
		return ;
	}
	for(int i=0;i<n;i++) {
		int ok=1;
		a[cnt]=i;
		for(int j=0;j<cnt;j++) {
			if(a[cnt]==a[j] || cnt-a[cnt]==j-a[j] || cnt+a[cnt]==j+a[j]) {
				ok=0;
				break;
			}
		}
		if(ok) dfs(cnt+1);
	}
}

int main()
{
	int i,j;
	for(n=1;n<=11;n++) {
		ans=0;
		memset(a,0,sizeof(a));
		dfs(0);
		f[n]=ans;
	}
	while(scanf("%d",&n)==1 &&n) {
		cout<<f[n]<<endl;
	}
	return 0;
}










HDU 2553 N皇後問題 (DFS_回溯)