1. 程式人生 > >hdu 2795 Billboard

hdu 2795 Billboard

close HERE it is scrip include build aps tip opened

hdu 2795 Billboard

Time Limit: 20000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
鏈接:http://acm.hdu.edu.cn/showproblem.php?pid=2795

Problem Description At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that‘s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed. Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement. Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can‘t be put on the billboard, output "-1" for this announcement. Sample Input
3 5 5 2 4 3 3 3 Sample Output 1 2 1 3 -1 題意:一個h*w的公告牌,要在其上貼公告。 輸入的是1*wi的w值,這些是公告的尺寸。 接下來要滿足的條件有:1、盡量往上,同一高度盡量靠左。2、求第n個廣告所在的行數。3、沒有合適的位置貼了則輸出-1。 題解:線段樹,一個點代表一行,能往左放就往左放; 大部分人是維護還剩多少,如果這樣寫,此題有一個巨坑點,就是只放一個並且不滿足條件,要先特判!!! 在這謝謝兩個好心人幫我看了很久 技術分享圖片
#include <bits/stdc++.h>

using namespace std;
int h,w,n;
const int maxn = 1000005;
struct Node {
    int v;
    Node *ls, *rs;
    void up(){
        v = min(ls->v, rs->v);
    }
}pool[maxn<<2], *tail = pool, *root, *zero;
void init(){
    zero = ++tail;
    zero->v=0;
    zero->ls = zero->rs = zero;
    //root = zero;
}
Node *build(int l = 1, int r = h){
    Node *nd = ++tail;
    nd-> v = 0;
    if(l == r)nd-> v = 0,nd->ls=nd->rs=zero;
    else {
        int m = (l + r) >> 1;
        nd->ls = build(l, m);
        nd->rs = build(m+1, r);
        nd->up();
        //printf("%d %d %d %d %d\n",l,r,nd->ls->v,nd->rs->v,nd->v);
    }
    return nd;
}
#define Ls l, m, nd->ls
#define Rs m+1, r, nd->rs
int modify(int del, int l = 1, int r = h, Node * nd = root){
    if(l == r){
        nd->v += del;
        return l;
    }
    int m = (l + r) >> 1;
    int ans = -1;
    if(nd->ls->v + del <= w)  
        ans = modify(del, Ls);
    else if(nd->rs->v + del <= w)  
        ans = modify(del, Rs);
    nd->up();
    return ans;

}
int main()
{
    while(scanf("%d%d%d",&h,&w,&n)==3){
        if(h > n)h=n;
        tail = pool;
        init();
        root = build();
        for(int i = 1; i <= n; i++){
            int ww;
            scanf("%d",&ww);
            if(ww+root->v>w)printf("-1\n");//lastmx
            else printf("%d\n",modify(ww));
        }

    }

    return 0;
}
View Code

hdu 2795 Billboard