1. 程式人生 > >1718: [Usaco2006 Jan] Redundant Paths 分離的路徑

1718: [Usaco2006 Jan] Redundant Paths 分離的路徑

order ber mit ger 雙向 end AD idt 技術

1718: [Usaco2006 Jan] Redundant Paths 分離的路徑

Time Limit: 5 Sec Memory Limit: 64 MB
鏈接:https://www.lydsy.com/JudgeOnline/problem.php?id=1718

Description

In order to get from one of the F (1 <= F <= 5,000) grazing fields (which are numbered 1..F) to another field, Bessie and the rest of the herd are forced to cross near the Tree of Rotten Apples. The cows are now tired of often being forced to take a particular path and want to build some new paths so that they will always have a choice of at least two separate routes between any pair of fields. They currently have at least one route between each pair of fields and want to have at least two. Of course, they can only travel on Official Paths when they move from one field to another. Given a description of the current set of R (F-1 <= R <= 10,000) paths that each connect exactly two different fields, determine the minimum number of new paths (each of which connects exactly two fields) that must be built so that there are at least two separate routes between any pair of fields. Routes are considered separate if they use none of the same paths, even if they visit the same intermediate field along the way. There might already be more than one paths between the same pair of fields, and you may also build a new path that connects the same fields as some other path.

為了從F(1≤F≤5000)個草場中的一個走到另一個,貝茜和她的同伴們有時不得不路過一些她們討厭的可怕的樹.奶牛們已經厭倦了被迫走某一條路,所以她們想建一些新路,使每一對草場之間都會至少有兩條相互分離的路徑,這樣她們就有多一些選擇. 每對草場之間已經有至少一條路徑.給出所有R(F-1≤R≤10000)條雙向路的描述,每條路連接了兩個不同的草場,請計算最少的新建道路的數量, 路徑由若幹道路首尾相連而成.兩條路徑相互分離,是指兩條路徑沒有一條重合的道路.但是,兩條分離的路徑上可以有一些相同的草場. 對於同一對草場之間,可能已經有兩條不同的道路,你也可以在它們之間再建一條道路,作為另一條不同的道路.

Input

* Line 1: Two space-separated integers: F and R * Lines 2..R+1: Each line contains two space-separated integers which are the fields at the endpoints of some path.

第1行輸入F和R,接下來R行,每行輸入兩個整數,表示兩個草場,它們之間有一條道路.

Output

* Line 1: A single integer that is the number of new paths that must be built.

最少的需要新建的道路數.

Sample Input

7 7
1 2
2 3
3 4
2 5
4 5
5 6
5 7

Sample Output

2

HINT

技術分享圖片

題解:邊雙連通分量裸題

技術分享圖片
#include<bits/stdc++.h>
using namespace std;
 
const int maxn = 10005, inf = 1000000008;
int du[maxn], dfn[maxn],low[maxn],h[maxn],place[maxn],tot,idx,scccnt;
bool ins[maxn], vis[maxn<<1];
struct edge{
    int v,nxt;
}G[maxn<<1];
stack <int> s;
void add(int u,int v){
    G[++tot].nxt = h[u]; h[u] = tot; G[tot].v = v;
}
void tarjan(int u, int d){
    dfn[u] = low[u] = ++idx;
    s.push(u); ins[u] = 1;
     
    for(int i = h[u]; i; i = G[i].nxt){
        if(vis[i^1])continue;
        vis[i] = 1;
        int v = G[i].v;
        if(!dfn[v]){
            tarjan(v, i);
            low[u] = min(low[u], low[v]);
        }
        else if(ins[v]) low[u] = min(low[u], dfn[v]);
    }
     
    if(low[u] == dfn[u]){
        scccnt++;
        while(1){
            int t = s.top();
            ins[t] = 0;
            place[t] = scccnt;
            s.pop();
            if(t == u)break;
        }
    }
}
int main(){
    int F, R, leaf = 0;
    tot = 1;
    scanf("%d%d",&F,&R);
    for(int i = 1; i <= R; i++){
        int u,v;
        scanf("%d%d",&u, &v);
        add(u, v); add(v, u);
    }
    for(int i = 1; i <= F; i++)
        if(!dfn[i])tarjan(i, inf);
    for(int i = 1; i <= F; i++)
        for(int j = h[i]; j; j = G[j].nxt){
            int v = G[j].v;
            if(place[i] != place[v])
                du[place[i]]++;
        }
    for(int i = 1; i <= scccnt; i++)
        if(du[i] == 1)leaf++;
    printf("%d\n",(leaf+1)/2);
}
View Code

1718: [Usaco2006 Jan] Redundant Paths 分離的路徑