1. 程式人生 > >[POJ2356] Find a multiple 鴿巢原理

[POJ2356] Find a multiple 鴿巢原理

first can pro iat tro tdi num name som

Find a multiple
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8776 Accepted: 3791 Special Judge

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3

Source

Ural Collegiate Programming Contest 1999
題解: 我們可以求出每個數的前綴和,如果有一項mod n等於0,那麽直接輸出它之前的所有數;
如果不存在,那麽qzh[i]%n的值一定落在[1,n-1]之間,根據鴿巢原理,n個數落在n-1個地方,必定有一個地方重復,即qzh[i] % n = qzh[j] % n; 所以qzh[i]%n - qzh[j]%n = 0, 即i 到 j 之間的所有數加起來就是n的倍數; 所以直接暴力判斷ok;
Code:
#include <iostream>
#include <cstdio>
#include  <map>
using namespace std;

int n;
int a[10010];
int qzh[10010];
map <int, int> mp;

int main()
{
    scanf("%d", &n);
    for (register int i = 1 ; i <= n ; i ++) scanf("%d", a + i);
    for (register int i = 1 ; i <= n ; i ++)
    {
        qzh[i] = qzh[i-1] + a[i];
        if (qzh[i] % n == 0) 
        {
            cout << i << endl;
            for (register int j = 1 ; j <= i ; j ++) printf("%d\n", a[j]);
            return 0;
        }
        if (mp[qzh[i]%n]!= 0) 
        {
            cout << i - mp[qzh[i]%n] << endl;
            for (register int j = mp[qzh[i]%n] + 1 ; j <= i ; j ++)
                printf("%d\n", a[j]);
            break;
        }
        mp[qzh[i]%n] = i;
    }
    return 0;
}

[POJ2356] Find a multiple 鴿巢原理