1. 程式人生 > >2018HDU多校訓練-3-Problem F. Grab The Tree

2018HDU多校訓練-3-Problem F. Grab The Tree

assume sco who cte NPU edi ins pla hat

Little Q and Little T are playing a game on a tree. There are n技術分享圖片 vertices on the tree, labeled by 1,2,...,n技術分享圖片 , connected by n?1技術分享圖片 bidirectional edges. The i技術分享圖片 -th vertex has the value of w技術分享圖片i技術分享圖片技術分享圖片 .
In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between x技術分享圖片
and y技術分享圖片 , he can‘t grab both x技術分享圖片 and y技術分享圖片 . After Q‘s move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T.
The final score of each player is the bitwise XOR sum of his choosen vertices‘ value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result.

Input The first line of the input contains an integer T(1T20)技術分享圖片 , denoting the number of test cases.
In each test case, there is one integer n(1n100000)技術分享圖片 in the first line, denoting the number of vertices.
In the next line, there are n技術分享圖片 integers w技術分享圖片1技術分享圖片,w技術分享圖片2技術分享圖片,...,w技術分享圖片n技術分享圖片(1w技術分享圖片i技術分享圖片10技術分享圖片9技術分享圖片)技術分享圖片 , denoting the value of each vertex.
For the next n?1技術分享圖片
lines, each line contains two integers u技術分享圖片 and v技術分享圖片 , denoting a bidirectional edge between vertex u技術分享圖片 and v技術分享圖片 .

Output For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D.

Sample Input 1 3 2 2 2 1 2 1 3

Sample Output Q 題解:由於是求異或,我們只需考慮每一位上的 1 的個數即可,比如:對於最高位,如果為偶數,那麽小Q只需選一個或者不選即可那麽小Q,小T最後該位上的數是相同的,如果為奇數,小Q選一個為必勝,因為小Q就選這一個,剩下都給小T,小T的最終結果必定小於小Q, 因此,我們只需要對每一位上的1的個數加一遍,如果有出現奇數個,則Q必勝,否者平局; 參考代碼為:
#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+5;
int w[maxn],u[maxn],v[maxn];
int main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);
	
	int T,n;
	cin>>T;
	while(T--)
	{
		cin>>n;
		bool flag=false;
		for(int i=1;i<=n;i++) cin>>w[i];
		for(int i=1;i<n;i++) cin>>u[i]>>v[i];
		for(int i=0;i<32;i++)
		{
			int cnt=0;
			for(int i=1;i<=n;i++)
			{
				if(w[i]&1) cnt++;
				w[i]>>=1;
			}
			if(cnt & 1) 
			{
				cout<<"Q"<<endl;
				flag=true;
				break;
			}
		}
		if(!flag) cout<<"D"<<endl;	
	}
	
	return 0;
}

  

2018HDU多校訓練-3-Problem F. Grab The Tree