1. 程式人生 > >POJ 3181(完全揹包、高精度)

POJ 3181(完全揹包、高精度)

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9693   Accepted: 3578

Description

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are:
 

        1 @ US$3 + 1 @ US$2

        1 @ US$3 + 2 @ US$1

        1 @ US$2 + 3 @ US$1

        2 @ US$2 + 1 @ US$1

        5 @ US$1

Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

5 3

Sample Output

5

 

題意就是很簡單的完全揹包,但是結果特別大。需要用兩個long long 陣列 記錄結果。

陣列 a[] 記錄 高位,陣列b[]記錄低 位 (對 1e18 取模結果)

這樣

a[j] = a[j] + a[j-cost[i]] + (b[j] + b[j-cost[i]])%M

b[j] = (b[j] + b[j-cost[i]])%M  => b[j] = (b[j]%M + b[j-cost[i]]%M)%M;

 

 

code : 

#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<vector>
#include<map>
#include<algorithm>
#include<string>
const unsigned long long M = 1e18;
using namespace std;
typedef long long LL;
int cost[100+5];
LL a[1000+5];
LL b[1000+5];
int n,k;

int main()
	{
		while(scanf("%d%d",&n,&k) != EOF){
			memset(a,0,sizeof(a));
			memset(b,0,sizeof(b));
			memset(cost,0,sizeof(cost));
//			for(int i = 0; i < k; ++i){
//				cost[i] = i+1;
//			}
			b[0] = 1;
			for(int i = 1; i <= k; ++i){
				for(int j = i; j <= n; ++j){
					a[j] = a[j] + a[j-i] + (b[j] + b[j-i])/M;//記錄高位
					b[j] = (b[j]%M  + b[j-i]%M)%M; //記錄低位
				}
			}			
			if(a[n])
				printf("%I64d",a[n]);
			printf("%I64d\n",b[n]);
		}	
	

		return 0;
	}