1. 程式人生 > >HDU - 4349 Xiao Ming's Hope(盧卡斯定理)

HDU - 4349 Xiao Ming's Hope(盧卡斯定理)

Problem Description

Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C(n,0)+C(n,1)+C(n,2)+...+C(n,n)=?". Of course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C(1,0)=C(1,1)=1, there are 2 odd numbers. When n is equal to 2, C(2,0)=C(2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want to let her down. Can you help him?

 

 

Input

Each line contains a integer n(1<=n<=108)

 

 

Output

A single line with the number of odd numbers of C(n,0),C(n,1),C(n,2)...C(n,n).

 

 

Sample Input

 

1 2 11

 

 

Sample Output

 

2 2 8

題意:求C(n,0),C(n,1),C(n,2)...C(n,n).當中有多少個奇數。 

思路:用的就是我一千從來沒聽說過的lucas定理,寫不出好的Blog 就轉載一下別人的吧

盧卡斯定理:https://blog.csdn.net/qq_40679299/article/details/80489761

本題為Lucas定理推導題,我們分析一下 C(n,m)%2,那麼由lucas定理,我們可以寫
成二進位制的形式觀察,比如 n=1001101,m是從000000到1001101的列舉,我們知道在該定理中
C(0,1)=0,因此如果n=1001101的0對應位置的m二進位制位為1那麼C(n,m) % 2==0,因此m對應n為0的
位置只能填0,而1的位置填0,填1都是1(C(1,0)=C(1,1)=1),不影響結果為奇數,並且保證不會
 出n的範圍,因此所有的情況即是n中0的位置m必須是0(c(0,0)=1),n中1位置對應m位置0,1的列舉,那麼結果很明顯就是:2^(n中1的個數)


 

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		int cnt=0;
		while(n>0)
		{
			if(n&1) cnt++;
			n>>=1;
		}
		cout<<pow(2,cnt)<<endl;
	}
	return 0;
 }