1. 程式人生 > >【Xiao Ming's Hope】【HDU - 4349】(盧卡斯定理)

【Xiao Ming's Hope】【HDU - 4349】(盧卡斯定理)

題目:
 

Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C(n,0)+C (n,1)+C (n,2)+...+C (n,n)=?". Of course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C (1,0)=C (1,1)=1, there are 2 odd numbers. When n is equal to 2, C (2,0)=C (2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want to let her down. Can you help him?

Input

Each line contains a integer n(1<=n<=10 8)

Output

A single line with the number of odd numbers of C (n,0),C (n,1),C (n,2)...C (n,n).

Sample Input

1
2
11

Sample Output

2
2
8

解題報告: 剛上來就有人在我身邊說是盧卡斯定理,後來就做這道題目,發現這個實質就是這個數字的二進位制中有1的個數,看似和盧卡斯定理沒啥關係,實際上就是C(n,m)%2,進行的盧卡斯優化,C(n,m)%2=Lucs(n/2,m/2)*C(n%2,m%2)%p;

所以最後實現的出來就是等價於2的二進位制數的1的數目次方。

ac程式碼:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;

int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int num=0;
		ll sum=1;
		while(n)
		{
			if(n&1)
				num++;
			n>>=1;
		}
		for(int i=0;i<num;i++)
		{
			sum*=2;
		}
		printf("%lld\n",sum);
	}
}