1. 程式人生 > >Island Transport HDU - 4280 網路流模板

Island Transport HDU - 4280 網路流模板

  In the vast waters far far away, there are many islands. People are living on the islands, and all the transport among the islands relies on the ships. 
  You have a transportation company there. Some routes are opened for passengers. Each route is a straight line connecting two different islands, and it is bidirectional. Within an hour, a route can transport a certain number of passengers in one direction. For safety, no two routes are cross or overlap and no routes will pass an island except the departing island and the arriving island. Each island can be treated as a point on the XY plane coordinate system. X coordinate increase from west to east, and Y coordinate increase from south to north. 
  The transport capacity is important to you. Suppose many passengers depart from the westernmost island and would like to arrive at the easternmost island, the maximum number of passengers arrive at the latter within every hour is the transport capacity. Please calculate it. 
Input 
  The first line contains one integer T (1<=T<=20), the number of test cases. 
  Then T test cases follow. The first line of each test case contains two integers N and M (2<=N,M<=100000), the number of islands and the number of routes. Islands are number from 1 to N. 
  Then N lines follow. Each line contain two integers, the X and Y coordinate of an island. The K-th line in the N lines describes the island K. The absolute values of all the coordinates are no more than 100000. 
  Then M lines follow. Each line contains three integers I1, I2 (1<=I1,I2<=N) and C (1<=C<=10000) . It means there is a route connecting island I1 and island I2, and it can transport C passengers in one direction within an hour. 
  It is guaranteed that the routes obey the rules described above. There is only one island is westernmost and only one island is easternmost. No two islands would have the same coordinates. Each island can go to any other island by the routes. 
Output 
  For each test case, output an integer in one line, the transport capacity. 
Sample Input 

5 7 
3 3 
3 0 
3 1 
0 0 
4 5 
1 3 3 
2 3 4 
2 4 3 
1 5 6 
4 5 3 
1 4 4 
3 4 2 
6 7 
-1 -1 
0 1 
0 2 
1 0 
1 1 
2 3 
1 2 1 
2 3 6 
4 5 5 
5 6 3 
1 4 6 
2 5 5 
3 6 4 
Sample Output 

6

這題是純的網路流,唯一需要注意的就是這是個無向圖,只要在加反向邊的時候直接流量設的和正向邊一樣即可,然後直接上模版;這個題需要在幾本板子上在進行一些剪枝才不會超時。

#include <iostream>
#include<queue>
#include<stdio.h>
#include<string.h>
#define inf 0x3f3f3f3f
using namespace std;
int head[100006];
struct code
{
    int to,v,nx;
} edge[200006];
int top;
void add(int s,int e,int v)
{
    edge[top].to=e;
    edge[top].v=v;
    edge[top].nx=head[s];
    head[s]=top++;
    edge[top].to=s;
    edge[top].v=v;
    edge[top].nx=head[e];
    head[e]=top++;
}
int dap[100006];
bool bfs(int s,int e)
{
    queue<int>p;
    memset(dap,0,sizeof(dap));
    p.push(s);
    dap[s]=1;
    while(!p.empty())
    {
        int u=p.front();
        p.pop();
        for(int i=head[u]; i!=-1; i=edge[i].nx)
        {
            if(edge[i].v>0&&dap[edge[i].to]==0)
            {
                dap[edge[i].to]=dap[u]+1;
                if(edge[i].to==e)
                    return true;
                p.push(edge[i].to);
            }
        }
    }
    if(dap[e]!=0)
        return true;
    else
        return false;
}
int dfs(int u,int e,int f)
{
    if(u==e||f==0)
        return f;
    int temp=f;
    for(int i=head[u]; i!=-1; i=edge[i].nx)
    {
        if(edge[i].v>0&&dap[edge[i].to]==dap[u]+1)
        {
            int di=dfs(edge[i].to,e,min(temp,edge[i].v));
            temp-=di;
            edge[i].v-=di;
            edge[i^1].v+=di;
            if(temp<=0)
                break;
        }
    }
    if(temp==f)
        dap[u]=inf;//就這一個剪枝卡超時
    return f-temp;
}
int max_flow(int s,int e)
{
    int ans=0;
    while(bfs(s,e))
        ans+=dfs(s,e,inf);
    return ans;
}
int main()
{
    int t,m,n,x,y,w,me,s,e;
    scanf("%d",&t);
    while(t--)
    {
        top=0;
        w=inf;
        me=-inf;
        scanf("%d%d",&n,&m);
        memset(head,-1,sizeof(head));
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&x,&y);
            if(x<w)
            {
                w=x;
                s=i;
            }
            if(x>me)
            {
                me=x;
                e=i;
            }
        }
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&x,&y,&w);
            add(x,y,w);
        }
        printf("%d\n",max_flow(s,e));
    }
    return 0;
}

附上匡斌大佬的終極板子

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
const int MAXN=100010;//點數的最大值
const int MAXM=400010;//邊數的最大值
const int INF=0x3f3f3f3f;
struct Node
{
    int from,to,next;
    int cap;
} edge[MAXM];
int tol;
int head[MAXN];
int dep[MAXN];
int gap[MAXN];//gap[x]=y :說明殘留網路中dep[i]==x的個數為y

int n;//n是總的點的個數,包括源點和匯點

void init()
{
    tol=0;
    memset(head,-1,sizeof(head));
}

void addadge(int u,int v,int w)
{
    edge[tol].from=u;
    edge[tol].to=v;
    edge[tol].cap=w;
    edge[tol].next=head[u];
    head[u]=tol++;
    edge[tol].from=v;
    edge[tol].to=u;
    edge[tol].cap=0;
    edge[tol].next=head[v];
    head[v]=tol++;
}
void BFS(int start,int end)
{
    memset(dep,-1,sizeof(dep));
    memset(gap,0,sizeof(gap));
    gap[0]=1;
    int que[MAXN];
    int front,rear;
    front=rear=0;
    dep[end]=0;
    que[rear++]=end;
    while(front!=rear)
    {
        int u=que[front++];
        if(front==MAXN)front=0;
        for(int i=head[u]; i!=-1; i=edge[i].next)
        {
            int v=edge[i].to;
            if(dep[v]!=-1)continue;
            que[rear++]=v;
            if(rear==MAXN)rear=0;
            dep[v]=dep[u]+1;
            ++gap[dep[v]];
        }
    }
}
int SAP(int start,int end)
{
    int res=0;
    BFS(start,end);
    int cur[MAXN];
    int S[MAXN];
    int top=0;
    memcpy(cur,head,sizeof(head));
    int u=start;
    int i;
    while(dep[start]<n)
    {
        if(u==end)
        {
            int temp=INF;
            int inser;
            for(i=0; i<top; i++)
                if(temp>edge[S[i]].cap)
                {
                    temp=edge[S[i]].cap;
                    inser=i;
                }
            for(i=0; i<top; i++)
            {
                edge[S[i]].cap-=temp;
                edge[S[i]^1].cap+=temp;
            }
            res+=temp;
            top=inser;
            u=edge[S[top]].from;
        }
        if(u!=end&&gap[dep[u]-1]==0)//出現斷層,無增廣路
            break;
        for(i=cur[u]; i!=-1; i=edge[i].next)
            if(edge[i].cap!=0&&dep[u]==dep[edge[i].to]+1)
                break;
        if(i!=-1)
        {
            cur[u]=i;
            S[top++]=i;
            u=edge[i].to;
        }
        else
        {
            int min=n;
            for(i=head[u]; i!=-1; i=edge[i].next)
            {
                if(edge[i].cap==0)continue;
                if(min>dep[edge[i].to])
                {
                    min=dep[edge[i].to];
                    cur[u]=i;
                }
            }
            --gap[dep[u]];
            dep[u]=min+1;
            ++gap[dep[u]];
            if(u!=start)u=edge[S[--top]].from;
        }
    }
    return res;
}
int main()
{
    int t,x,y,w,me,s,e,m;
    scanf("%d",&t);
    while(t--)
    {
        init();
        w=INF;
        me=-INF;
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&x,&y);
            if(x<w)
            {
                w=x;
                s=i;
            }
            if(x>me)
            {
                me=x;
                e=i;
            }
        }

        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&x,&y,&w);
            addadge(x,y,w);
            addadge(y,x,w);
        }
        printf("%d\n",SAP(s,e));
    }
    return 0;
}