1. 程式人生 > >HDU-2101 A + B Problem Too(語法練習題)

HDU-2101 A + B Problem Too(語法練習題)

A + B Problem Too

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20917 Accepted Submission(s): 15417

Problem Description
This problem is also a A + B problem,but it has a little difference,you should determine does (a+b) could be divided with 86.For example ,if (A+B)=98,you should output no for result.

Input
Each line will contain two integers A and B. Process to end of file.

Output
For each case, if(A+B)%86=0,output yes in one line,else output no in one line.

Sample Input
1 1
8600 8600

Sample Output
no
yes

Source
HDU 2007-6 Programming Contest

問題簡述:

  輸入兩個數,如果兩數之和為86的倍數則輸出"yes",否則輸出"no"。

問題分析:

  求和後取餘判斷即可。

程式說明:

  使用c++標準輸入輸入流。

程式實現:

#include<iostream>
using namespace std;

int main()
{
    int a,b;
    while(cin>>a>>b)
    {
        if((a+b)%86==0) cout<<"yes"<<endl;
        else cout<<"no"<<endl;
    }
}