1. 程式人生 > >hdu2101——A + B Problem Too

hdu2101——A + B Problem Too

A + B Problem Too

This problem is also a A + B problem,but it has a little
difference,you should determine does (a+b) could be divided with
86.For example ,if (A+B)=98,you should output no for result.

Input

Each line will contain two integers A and B. Process to end of file.

Output

For each case, if(A+B)%86=0,output yes in one line,else output no in
one line.

Sample Input

1 1
8600 8600

Sample Output

no
yes

程式分析:while迴圈來多次輸入,if判斷(a+b)是否為86的倍數,!!程式要求換行!!
AC通過程式:

#include<stdio.h>
int main()
{
	int a,b;
	while(scanf("%d %d",&a,&b)!=EOF)
	{
		if((a+b)%86==0)
		{
			printf("yes\n");
		}else printf("no\n");
	}
	return 0;
}

小小改進後:

#include<stdio.h>
int main()
{
	int a,b;
	while(scanf("%d %d",&a,&b)!=EOF)
		(a+b)%86==0?printf("yes\n"):printf("no\n");
	return 0;
}