1. 程式人生 > >Strange Way to Express Integers [擴充套件中國剩餘定理]

Strange Way to Express Integers [擴充套件中國剩餘定理]

Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:
Choose k different positive integers a1, a2, …, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1, a2, …, ak are properly chosen, m can be determined, then the pairs (ai, ri) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

Line 1: Contains the integer k.
Lines 2 ~ k + 1: Each contains a pair of integers ai, ri (1 ≤ i ≤ k).
Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input

2
8 7
11 9
Sample Output

31


擴充套件中國剩餘定理模板

#include<bits/stdc++.h>
#define LL long long
using namespace std;
LL k,x,y,a,m,ans,lcm,gcd;
void exgcd(LL a,LL b){
	if(!b){x=1,y=0,gcd=a; return;}
	exgcd(b,a%b); LL x1=y,y1=x-a/b*y; x=x1,y=y1;
}
int main(){
	cin>>k>>m>>a;
	ans = a%m , lcm=m;
	for(int i=2;i<=k;i++){
		cin>>m>>a;
		LL c = (a - ans%m + m) % m;
		exgcd(lcm,m); 
		if(c%gcd){printf("-1"); return 0;}
		x = (x * (c/gcd)) % (m/gcd);
		ans += x * lcm; lcm *= (m/gcd);
		ans = (ans%lcm + lcm) % lcm;
	}cout<<ans; return 0;
}