1. 程式人生 > >PAT (Advanced Level) Practice 1003(Dijkstra)

PAT (Advanced Level) Practice 1003(Dijkstra)

1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains Nintegers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

 分析:題目要求求最短路徑條數與最大點權和,用Dijkstra來解決。過程中,每找到一條最短路徑(d[v] == d[u] + G[u][v])更新一次最短路徑條數,每找到更大的點權和(c[v] < c[u] + C[v])就更新一次點權和。最後輸出終點的最短路徑條數與點權和。

 程式碼:

#include<iostream>
#include<algorithm>
#define MAXN 501
#define INF 0x3fffffff
using namespace std;
int G[MAXN][MAXN];
int d[MAXN];
int C[MAXN];
int c[MAXN];
int visit[MAXN] = { 0 };
int num[MAXN];
int N, M, C1, C2;
void dijkstra(int start) {
	fill(d, d + MAXN, INF);
	fill(num, num + MAXN, 1);
	d[start] = 0;
	c[start] = C[start];
	for (int i = 0; i < N; i++) {
		int u = -1, minN = INF;
		for (int j = 0; j < N; j++) {
			if (visit[j] == 0 && d[j] < minN) {
				u = j;
				minN = d[j];
			}
		}
		if (u == -1) {
			return;
		}
		visit[u] = 1;
		for (int v = 0; v < N; v++) {
			if (G[u][v] != INF && visit[v] == 0) {
				if (d[v] > d[u] + G[u][v]) {
					d[v] = d[u] + G[u][v];
					c[v] = c[u] + C[v];
					num[v] = num[u];
				}else if (d[v] == d[u] + G[u][v]) {
					if (c[v] < c[u] + C[v]) {
						c[v] = c[u] + C[v];
					}
					num[v] += num[u];
				}
			}
		}
	}
}
int main() {
	cin >> N >> M >> C1 >> C2;
	for (int i = 0; i < N; i++) {
		cin >> C[i];
	}
	fill(G[0], G[0] + MAXN * MAXN, INF);
	for (int i = 0; i < M; i++) {
		int u, v, w;
		cin >> u >> v >> w;
		G[u][v] = G[v][u] = w;
	}
	dijkstra(C1);
	cout << num[C2] << ' ' << c[C2] << endl;
	return 0;
}