1. 程式人生 > >JAVA基礎語法2

JAVA基礎語法2

做乘法 Time Limit: 1000 ms Memory Limit: 65536 KiB Submit Statistic Problem Description

請用C語言編寫一個程式。此程式接收一個正整數N,然後列印輸出“N次N*(1->N)格式”的資料。例如:此程式接收正整數5,那會輸出以下格式的資料: 5*1=5 5*2=10 5*3=15 5*4=20 5*5=25

Input

只有一個正整數N(N<=100)。 Output

輸出共N行資料,如上面的例子所示。 Sample Input

5 Sample Output

5*1=5 5*2=10 5*3=15 5*4=20 5*5=25

import java.util.Scanner;
public class Main
{
    public static void main(String[] args) 
    {
         Scanner reader = new Scanner(System.in);
          int N = reader.nextInt();
          for(int i=1;i<=N;i++)
          {
              int M=N*i;
              System.out.printf("%d*%d=%d\n"
,N,i,M); } } }

C語言實驗——for迴圈列印圖形(迴圈結構) Time Limit: 1000 ms Memory Limit: 65536 KiB Submit Statistic Problem Description

通過使用雙重for迴圈語句,列印下列圖形: 提交 Input

Output

Sample Input

Sample Output

*

*

import java.util.Scanner;
public class Main
{
    public static void main(String[] args) 
    {
         Scanner reader = new
Scanner(System.in); for(int i=1;i<=4;i++) { for(int j=4-i;j>=1;j--) { System.out.print(" "); } for(int j=1;j<=2*i-1;j++) { System.out.print("*"); } System.out.printf("\n"); } for(int i=3;i>=1;i--) { for(int j=i;j<=3;j++) { System.out.print(" "); } for(int j=2*i-1;j>=1;j--) { System.out.print("*"); } System.out.print("\n"); } } }

期末考試之分等級 Time Limit: 1000 ms Memory Limit: 65536 KiB Submit Statistic Problem Description

期末考試結束了,老師想要根據學生們的成績劃分出等級。共有5個等級A,B,C,D和E。 劃分方法如下,90分(含90)以上的為A,80~90(含80)間的為B,70~80(含70)間的為C, 60~70(含60)的為D,不及格的為E。 根據輸入的成績,程式設計輸出各個級別段人數。

Input

輸入第一行包含一個正整數N(N<= 100)代表學生的數目,接下來有N行資料每行一個整數(0~100)代表 一個學生的成績。 Output

輸出有五行格式如下: A nA B nB C nC D nD E nE 其中A,B,C,D,E代表等級,nA,nB等代表個等級的人數,等級和人數之間有一個空格。 Sample Input

6 66 73 85 99 100 59 Sample Output

A 2 B 1 C 1 D 1 E 1

import java.util.Scanner;
public class Main
{
    public static void main(String[] args) 
    {
         Scanner reader = new Scanner(System.in);
         int N=reader.nextInt();
         int a=0,b=0,c=0,d=0,e=0;
         for(int i=1;i<=N;i++)
         {
             int X=reader.nextInt();
             if(X>=90)a++;
             else if(X>=80)b++;
             else if(X>=70)c++;
             else if(X>=60)d++;
             else e++;
         }
         System.out.printf("A %d\nB %d\nC %d\nD %d\nE %d\n",a,b,c,d,e);
    }
}

C語言實驗——矩陣轉置 Time Limit: 1000 ms Memory Limit: 65536 KiB Submit Statistic Problem Description

輸入N*N的矩陣,輸出它的轉置矩陣。 Input

第一行為整數N(1≤N≤100)。 接著是一個N*N的矩陣。 Output

轉置矩陣。 Sample Input

2 1 2 1 2 Sample Output

1 1 2 2

import java.util.Scanner;
public class Main
{
    public static void main(String[] args) 
    {
         Scanner reader = new Scanner(System.in);
         int A[][];
         A=new int[100][100];
         int n=reader.nextInt();
         for(int i=0;i<=n-1;i++)
         {
            for(int j=0;j<=n-1;j++)
            {
                A[i][j]=reader.nextInt();
            }
         }
         for(int i=0;i<=n-1;i++)
         {
            for(int j=0;j<=n-1;j++)
            {
                if(j!=n-1)
                    System.out.printf("%d ",A[j][i]);
                else
                    System.out.printf("%d\n",A[j][i]);
            }
         }

    }
}

C語言實驗——矩陣下三角元素之和 Time Limit: 1000 ms Memory Limit: 65536 KiB Submit Statistic Problem Description

輸入一個正整數n(1<=n<=10),再輸入n*n的矩陣,要求求該矩陣的下三角元素之和。 Input

輸入包括n+1行。 第一行為整數n; 接下來的n行為矩陣資料。 Output

矩陣的下三角元素之和。 Sample Input

5 1 2 3 4 5 2 3 4 5 6 3 4 5 6 7 4 5 6 7 8 5 6 7 8 9 Sample Output

75

import java.util.Scanner;

import com.sun.jndi.url.iiopname.iiopnameURLContextFactory;
public class Main
{
    public static void main(String[] args) 
    {
         Scanner reader = new Scanner(System.in);
         int A[][];
         A=new int[11][11];
         int n=reader.nextInt();
         for(int i=0;i<=n-1;i++)
         {
            for(int j=0;j<=n-1;j++)
            {
                A[i][j]=reader.nextInt();
            }
         }
         int sum=0;
         for(int i=0;i<=n-1;i++)
         {
             for(int j=0;j<=i;j++)
             {
                 sum=sum+A[i][j];
             }
         }
         System.out.println(sum);
    }
}

排序 Time Limit: 1000 ms Memory Limit: 32678 KiB Submit Statistic Problem Description

給你N(N<=100)個數,請你按照從小到大的順序輸出。

Input

輸入資料第一行是一個正整數N,第二行有N個整數。

Output

輸出一行,從小到大輸出這N個數,中間用空格隔開。

Sample Input

5 1 4 3 2 5 Sample Output

1 2 3 4 5

import java.util.Scanner;

import com.sun.jndi.url.iiopname.iiopnameURLContextFactory;
public class Main
{
    public static void main(String[] args) 
    {
         Scanner reader = new Scanner(System.in);
         int A[];
         A=new int [101];
         int N=reader.nextInt();
         for(int i=0;i<=N-1;i++)
         {
            A[i]=reader.nextInt(); 
         }
         int t;
         for(int i=0;i<=N-2;i++)
         {
             for(int j=0;j<=N-2-i;j++)
             {
                 if(A[j]>A[j+1])
                 {
                     t=A[j];A[j]=A[j+1];A[j+1]=t;
                 }
             }
         }
         for(int i=0;i<=N-1;i++)
         {
             if(i!=N-1)
            System.out.printf("%d ",A[i]);
             else
            System.out.printf("%d\n",A[i]);  
         }
    }
}

期末考試之排名次 Time Limit: 1000 ms Memory Limit: 65536 KiB Submit Statistic Problem Description

期末考試結束了,童鞋們的成績也出來的了,可是為了排名次可忙壞了老師,因為學生太多了。這時,老師把這個任務交給了你,希望你能幫老師完成。作為IT人,你當然不能用笨笨的人工方法了,程式設計解決才是好辦法。 共有三門課,語文、數學和英語,要求根據學生的各科成績計算出其總成績,並根據總成績從高到低排序。 Input

第一行一個整數N(N<=100),代表學生的人數。 接下來的N行資料,每行有三個整數,C,M,E分別代表一個學生語文、數學和英語的成績。 Output

一共N行,每行一個數,從大到小,分別代表各個學生的總成績。 Sample Input

3 70 80 90 59 59 59 100 100 100 Sample Output

300 240 177

import java.util.Scanner;

import com.sun.jndi.url.iiopname.iiopnameURLContextFactory;
public class Main
{
    public static void main(String[] args) 
    {
         Scanner reader = new Scanner(System.in);
         int A[];
         A=new int [101];
         int N=reader.nextInt();
         for(int i=0;i<=N-1;i++)
         {
            int a=reader.nextInt(); 
            int b=reader.nextInt(); 
            int c=reader.nextInt(); 
            A[i]=a+b+c;
         }
         int t;
         for(int i=0;i<=N-2;i++)
         {
             for(int j=0;j<=N-2-i;j++)
             {
                 if(A[j]<A[j+1])
                 {
                     t=A[j];A[j]=A[j+1];A[j+1]=t;
                 }
             }
         }
         for(int i=0;i<=N-1;i++)
         {
            System.out.printf("%d\n",A[i]);  
         }
    }
}