1. 程式人生 > >SDUT OJ順序表應用4-2:元素位置互換之逆置演算法(資料改進)

SDUT OJ順序表應用4-2:元素位置互換之逆置演算法(資料改進)

順序表應用4-2:元素位置互換之逆置演算法(資料改進)

Time Limit: 80 ms Memory Limit: 600 KiB

Problem Description

一個長度為len(1<=len<=1000000)的順序表,資料元素的型別為整型,將該表分成兩半,前一半有m個元素,後一半有len-m個元素(1<=m<=len),設計一個時間複雜度為O(N)、空間複雜度為O(1)的演算法,改變原來的順序表,把順序表中原來在前的m個元素放到表的後段,後len-m個元素放到表的前段。 注意:交換操作會有多次,每次交換都是在上次交換完成後的順序表中進行。

Input

第一行輸入整數len(1<=len<=1000000),表示順序表元素的總數;

第二行輸入len個整數,作為表裡依次存放的資料元素;

第三行輸入整數t(1<=t<=30),表示之後要完成t次交換,每次均是在上次交換完成後的順序表基礎上實現新的交換;

之後t行,每行輸入一個整數m(1<=m<=len),代表本次交換要以上次交換完成後的順序表為基礎,實現前m個元素與後len-m個元素的交換;

Output

輸出一共t行,每行依次輸出本次交換完成後順序表裡所有元素。

Sample Input

10
1 2 3 4 5 6 7 8 9 -1
3
2
3
5

Sample Output

3 4 5 6 7 8 9 -1 1 2
6 7 8 9 -1 1 2 3 4 5
1 2 3 4 5 6 7 8 9 -1

Hint

Source

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAX = 1000000+10;
int a[MAX];
int main()
{
    int len, t, m;
    scanf("%d", &len);
    for(int i = 1; i<=len; ++i)
		scanf("%d", &a[i]);
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d", &m);
		for(int i = 1; i<=len/2; ++i)
			swap(a[i], a[len-i+1]);
		for(int i = 1; i<=(len-m)/2; ++i)
			swap(a[i], a[len-m-i+1]);
		for(int i = 1; i<=m/2;++i)
			swap(a[i+len-m], a[len-i+1]);
		for(int i = 1; i<=len; ++i)
			printf("%d%c", a[i], (i==len)?'\n':' ');
	}
 
 
	return 0;
}