1. 程式人生 > >【水】HDU 2017 字串統計

【水】HDU 2017 字串統計

Time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 65536/32768 K (Java/Others)
[顯示標籤]
Description
對於給定的一個字串,統計其中數字字元出現的次數。
Input
輸入資料有多行,第一行是一個整數n,表示測試例項的個數,後面跟著n行,每行包括一個由字母和數字組成的字串。
Output
對於每個測試例項,輸出該串中數值的個數,每個輸出佔一行。
Sample Input

2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf

Sample Output

6
9

Hint
lcy
Source
  C語言程式設計練習(三)  
Related problem
2015 2013 2012 2010 2016

遍歷一下再做判斷就好了啊.這裡用的了string,跟字串差不多,不過其長度用size()得出。

程式碼如下:

#include <iostream>
#include <string.h>
using namespace std;

int main ()
{
int n;
cin>>n;
while(n--)
{
string a;
int count=0;
cin>>a;
for(int i=0;i<a.size();i++)
{
if(a[i]<='9'&&a[i]>='0')
    count++;
}
cout<<count<<endl;

}

}