1. 程式人生 > >HDU 2017 字串統計

HDU 2017 字串統計

                                            字串統計

Description

對於給定的一個字串,統計其中數字字元出現的次數。

Input

輸入資料有多行,第一行是一個整數n,表示測試例項的個數,後面跟著n行,每行包括一個由字母和數字組成的字串。

Output

對於每個測試例項,輸出該串中數值的個數,每個輸出佔一行。

Sample Input

2 asdfasdf123123asdfasdf asdf111111111asdfasdfasdf

Sample Output

6 9

#include<cstring>
#include<cstdio>
#include<ctype.h>
using namespace std;

int main()
{
    char s[100000];
    int n,i;
    scanf("%d",&n);
      getchar();
        while(n--)
        {
            int x=0;
            gets(s);
            for(i=0;i<strlen(s);i++)
            {
                if(isdigit(s[i]))
                    x++;
            }
                printf("%d\n",x);
        }


    return 0;
}