1. 程式人生 > >【PTA】——資料結構——01-複雜度2 Maximum Subsequence Sum

【PTA】——資料結構——01-複雜度2 Maximum Subsequence Sum

01-複雜度2 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10 -10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

思路:

利用課上老師講過的演算法2,4分別實現,尤其要注意當資料中只有負數和0的時候。自己處理的時候弄得比較繁瑣,有用了一個函式來判斷陣列中是否只有負數和0。網上參考之後,將maxsum初始化為-1,這樣就可以了。

程式碼: 

演算法2

#include <stdio.h>

void MaxSubseqSum2( int a[], int N);

int main(int argc,const char *argv[])
{
	int k;
	scanf("%d",&k);
	int a[k];
	for(int i=0;i<k;i++)
	{
		scanf("%d",&a[i]);
	}
	MaxSubseqSum2(a,sizeof(a)/sizeof(a[0]));
	return 0;
}

void MaxSubseqSum2( int a[], int N)
{ 
    int flag=0;
    int *p1=a,*q1=&a[N-1];//定義指標用於指向最大子列和的左端和右端 
    int thissum=0,maxsum=-1;
    for(int i=0;i<N;i++)
	{
    	thissum=0;
    	for(int j=i;j<N;j++)
		{
    		thissum+=a[j];
    		if(thissum>maxsum)
			{
				flag=1; 
				maxsum=thissum;
				p1=&a[i];
				q1=&a[j];
			}
		}
	}
    if(!flag)
   {
      printf("%d %d %d",0,*p1,*q1);
   }else
   {
      printf("%d %d %d",maxsum,*p1,*q1);
   }
}

演算法4

void MaxSubseqSum4(int a[], int N)
{ 
    int *ml=a,*mr=&a[N-1];
    int *l=a;
    int thissum=0,maxsum=-1;
    int flag=0;
    for(int i=0;i<N;i++)
	{
    	thissum+=a[i];
    	if(thissum>maxsum)
		{
			flag=1;
    		maxsum=thissum;
    		ml=l;//需要注意的點
    		mr=&a[i];
		}else if(thissum<0)
		{
			l=&a[i+1];
			thissum=0;
		}
	}
	if(!flag)
	{
		printf("%d %d %d",0,*ml,*mr);
	}else
    {
	    printf("%d %d %d",maxsum,*ml,*mr);
    }
}