1. 程式人生 > >PTA 01-複雜度2 Maximum Subsequence Sum (25 分)

PTA 01-複雜度2 Maximum Subsequence Sum (25 分)

01-複雜度2 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, …, N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

我這渣渣英語,真的。。。。搞了一早上,以為輸出的是:最大序列和 下標 下標;其實,輸出的是:最大序列和 下標對應的值 下標對應的值。

這個裡面注意的是,如果全部是負數,應該輸出0 a[0] a[n-1],如果有負數有0,應該輸出0 0 0

具體思路:設定一個flag,如果在向後加序列的時候出現和為負數,那就從頭開始加,開頭的下標就要從下一個下標開始,然後每次符合要求都記錄這次的start和end

#include <stdio.h>
int main()
{
    int n, i, flag=0;
    scanf("%d", &n);
    int a[n];
    for(i=0;i<n;i++){
        scanf("%d", &a[i]);
    }
    int maxNum=0,ThisNum=0, start=0, Thisstart=0, end=n-1;
    
    for(i=0;i<n;i++){
        ThisNum+=a[i];
        if(flag==1){
            Thisstart=i;
            flag=0;
        }
        if(ThisNum>maxNum ||(ThisNum>=maxNum && maxNum==0)){
            // 符合條件
            // ThisNum>=maxNum && maxNum==0 這個是為了保證有負數有0的時候輸出0 0 0
            maxNum=ThisNum;
            start = Thisstart;
            end = i;
        }
        else if(ThisNum<0){
            // 不符合條件
            flag=1;
            ThisNum=0;
        }
    }
    
    printf("%d %d %d", maxNum, a[start], a[end]);
    return 0;
}
/*
10
-10 1 2 3 4 -5 23 3 7 -21
10
-10 -1 -2 -1 0 -5 -23 -3 -7 -21
 */