1. 程式人生 > >【PAT甲級】1007 Maximum Subsequence Sum (25 分)

【PAT甲級】1007 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

【翻譯】 :輸入K,表示接下來有K個數,在這有K個數的序列中,找出一個子序列,這個子序列的和最大,長度儘量長。

輸出序列和,起點的數,終點的數(不是起點終點的下標),行尾沒有空格,如果最大和不唯一,輸出更小的下標時的數,如果最大和小於0,輸出0.

【思路】:temp是當前序列和,sum是最大序列和,left,right記載序列起點終點下標,tempindex記載當前序列和的起點,temp從序列頭頭開始加,如果temp<0那麼前面的都丟棄,因為負數只會減少序列和,此時更新tempindex下標,如果temp>0了,這時候再看他是否大於sum,如果比之前得出的最大和大,那麼就更新最大和,和最大和情況下的左右下標。

#include <iostream>
using namespace std;
int a[10002];
 
int main(){
	int k;
	cin>>k;
	
	int left = 0,right = k - 1,temp = 0,tempindex = 0,sum = -1;
	
	for(int i = 0; i < k; i++){
		cin>>a[i];
		temp += a[i];
		if(temp < 0){
			temp = 0;//
			tempindex = i + 1;
		}else if(temp > sum){
			left = tempindex;
			right = i;
			sum = temp;
		}
	}
	if(sum < 0) sum = 0;
	cout<<sum<<" "<<a[left]<<" "<<a[right];
	return 0;
}