1. 程式人生 > >3951】Coin Game (博弈,猜規律,對稱博弈)

3951】Coin Game (博弈,猜規律,對稱博弈)

題幹:

After hh has learned how to play Nim game, he begins to try another coin game which seems much easier. 

The game goes like this:  Two players start the game with a circle of n coins.  They take coins from the circle in turn and every time they could take 1~K continuous coins.  (imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn't take 1, 3, 4, because 1 and 3 aren't continuous)  The player who takes the last coin wins the game.  Suppose that those two players always take the best moves and never make mistakes.  Your job is to find out who will definitely win the game.

Input

The first line is a number T(1<=T<=100), represents the number of case. The next T blocks follow each indicates a case.  Each case contains two integers N(3<=N<=10 9,1<=K<=10).

Output

For each case, output the number of case and the winner "first" or "second".(as shown in the sample output)

Sample Input

2
3 1
3 2

Sample Output

Case 1: first
Case 2: second

解題報告:

   k為1的時候需要特殊處理。

   k>=2的時候,看是否可以一次取完,如果無法一次取完,那一定後手勝,因為不管點數是奇數還是偶數,你取一波,我一定可以對稱的取另一波,這樣得到的還是一個對稱的,這樣就可以保證後手一定能贏。

AC程式碼:

#include<bits/stdc++.h>

using namespace std;
int n,k;
int main()
{
    int t,iCase=0;
    cin>>t;
    while(t--) {
        scanf("%d%d",&n,&k);
        printf("Case %d: ",++iCase);
        if(k==1) {
        	if(n%2==1) puts("first");
        	else puts("second");
		}
        else if(k>=n) puts("first");
        else puts("second");
    }
    return 0;
}