1. 程式人生 > >AVL樹——自平衡二叉搜尋樹

AVL樹——自平衡二叉搜尋樹

概念

AVL(Adelson-Velskii and Landis)樹得名於它的發明者 G.M. Adelson-Velsky 和 E.M. Landis,他們在 1962 年的論文《An algorithm for the organization of information》中發表了它。
AVL樹是一種自平衡二叉搜尋樹。

特徵

  1. 滿足二叉搜尋樹的特徵,即任何一個節點的值比左孩子的值大,比右孩子的值小
  2. 在二叉搜尋樹的基礎上,任何一個節點的左右子樹高度差不超過1

構建AVL樹

參考部落格:https://www.cnblogs.com/skywang12345/p/3576969.html

出現不平衡的4種情況


  1. LL: LeftLeft,也稱為"左左"。插入或刪除一個節點後,根節點的左子樹的左子樹還有非空子節點,導致"根的左子樹的高度"比"根的右子樹的高度"大2,導致AVL樹失去了平衡。
  2. RR:RightRight,稱為"右右"。插入或刪除一個節點後,根節點的右子樹的右子樹還有非空子節點,導致"根的右子樹的高度"比"根的左子樹的高度"大2,導致AVL樹失去了平衡。
  3. LR:LeftRight,也稱為"左右"。插入或刪除一個節點後,根節點的左子樹的右子樹還有非空子節點,導致"根的左子樹的高度"比"根的右子樹的高度"大2,導致AVL樹失去了平衡。
  4. RL:RightLeft,稱為"右左"。插入或刪除一個節點後,根節點的右子樹的左子樹還有非空子節點,導致"根的右子樹的高度"比"根的左子樹的高度"大2,導致AVL樹失去了平衡。

旋轉

1. LL的旋轉

在這裡插入圖片描述

2. RR的旋轉

3. LR的旋轉

4. RL的旋轉

在這裡插入圖片描述

練習題

PAT 1066 Root of AVL Tree

Description

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.
在這裡插入圖片描述




在這裡插入圖片描述

Input Specification

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

AC code

程式碼參考:https://www.liuchuo.net/archives/2178

#include <stdio.h>
#include <iostream>
using namespace std;

struct node{
    int val;
    struct node *left, *right;
};

int getHeight(node *root){
    if(root == NULL) return 0;
    return max(getHeight(root->left), getHeight(root->right)) + 1;
}

node *rotateLeft(node *root){
    node *t = root->right;
    root->right = t->left;
    t->left = root;
    return t;
}

node *rotateRight(node *root){
    node *t = root->left;
    root->left = t->right;
    t->right = root;
    return t;
}

node *rotateLeftRight(node *root){
    root->left = rotateLeft(root->left);
    return rotateRight(root);
}

node *rotateRightLeft(node *root){
    root->right = rotateRight(root->right);
    return rotateLeft(root);
}

node *insert(node *root, int val){
    if(root == NULL){
        root = new node();
        root->val = val;
        root->left = NULL; root->right = NULL;
    }else if(val < root->val){
        root->left = insert(root->left, val);
        if(getHeight(root->left) - getHeight(root->right) == 2)
            root = val < root->left->val? rotateRight(root): rotateLeftRight(root);
    }else{
        root->right = insert(root->right, val);
        if(getHeight(root->left) - getHeight(root->right) == -2)
            root = val > root->right->val? rotateLeft(root): rotateRightLeft(root);
    }
    return root;
}

int main(){
    int n, val;
    scanf("%d", &n);
    node *root = NULL;
    for(int i = 0; i < n; i++){
        scanf("%d", &val);
        root = insert(root, val);
    }
    printf("%d", root->val);
    return 0;
}