1. 程式人生 > >HDU 6216 (2017icpc青島網路賽)

HDU 6216 (2017icpc青島網路賽)

A Cubic number and A Cubic Number

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others) Total Submission(s): 2478    Accepted Submission(s): 1015  

Problem Description

A cubic number is the result of using a whole number in a multiplication three times. For example, 3×3×3=27 so 27 is a cubic number. The first few cubic numbers are 1,8,27,64 and 125. Given an prime number p. Check that if p is a difference of two cubic numbers.

Input

The first of input contains an integer T (1≤T≤100) which is the total number of test cases. For each test case, a line contains a prime number p (2≤p≤1012).

Output

For each test case, output 'YES' if given p is a difference of two cubic numbers, or 'NO' if not.

Sample Input

10 2 3 5 7 11 13 17 19 23 29

Sample Output

NO NO NO YES NO NO NO YES NO NO

Source

Recommend

liuyiding

題目大意:

先輸入一個 n  

然後判斷之後輸入的 n 個質數中能夠滿足 與兩個不同數的立方之差相等

若滿足條件 輸出YES 否則輸出 NO

思考:

隊友先看的這題 但是她把資料範圍看錯了 以為是1000  直接暴力模擬 WA了兩次

然後就交給我了 只告訴我 判斷立方差 (我就直接忽略了質數這個關鍵的點

改了資料範圍 發現果斷超時 (畢竟最大有10000

比賽開始大概30分鐘 兩個隊伍已經A了 但是我們還在TLE 

我認真地想了想 可能是線段樹 (判斷多個連續區間相加的和 是否相等於輸入的值

就找了一個線段樹模板 改了一下就交題了

還是超時

聽到別的隊說有規律 可是就是想不出來啊啊啊啊啊啊

比賽結束之後 馬上補題 第一個A題的小姐姐告訴我 

就是數學題啊(也可以打表找規律

分析:

(看圖片吧,打字不方便...)

所以 如果 n 滿足 n = 3 * x * x + 3 * x + 1 或者  n = 3 * x * x - 3 * x + 1(x是整數)

以上兩個等式作用相同 是 a 與 b 的相互轉化

放程式碼:

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <map>
#include <vector>
#include <stdlib.h>
#include <set>
#include <queue>
#include <malloc.h>
using namespace std;
int main()
{
    int t;
    __int64 n;
    scanf("%d",&t);
    while (t--)
    {
        bool  flag = false;
        scanf("%I64d",&n);
        if ((n-1)%3==0)
        {
            long long mm = (long long)sqrt((n-1)/3);
            if (mm*(mm+1) ==(n-1)/3)
                flag = true;
        }
        if ( flag == false)
            printf("NO\n");
        else printf("YES\n");
    }
    return 0;
}

程式碼其實很簡單 只要能推匯出數學公式就能打出來了...

(以後一定好好打表 

很久沒寫部落格了 (暗示很久沒好好做題了emmm