1. 程式人生 > >MOOC資料結構課程 題集16 Saving James Bond

MOOC資料結構課程 題集16 Saving James Bond

06-圖2 Saving James Bond - Easy Version (25 分)

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line "Yes" if James can escape, or "No" if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No

拯救007,聽起來很吊的樣子

本題完全可以不用臨接表和臨接矩陣,直接用一個結構體陣列儲存座標,然後再用公式算兩點間距離就可以了

 不過因為島本身有寬度,所以第一跳要單獨判斷,之後就可以用DFS了,每次DFS都要先判斷一次是否可以上岸,可以就返回

若DFS完了沒有出路,說明這個圖可能不是連通圖,就要回到原點重新選一個點開始DFS。

#include <iostream>
#include <cmath>
#define ISLAND_WADTH 15
#define ElementType Point

typedef struct _Point
{
	int x;
	int y;
}Point;

typedef struct _GNode
{
	int Nv;
	int JP_distance;
	ElementType *point;
}Graph;

void creat_Graph(Graph *, int num_v, int num_e);
bool save007(Graph *);
bool DFS(Graph *, int start_pot, bool visited[]);
bool Is_safe(Point, int jump_distance);
bool Jump(Point start_pot, Point, int jump_distance);
bool FirstJump(Point first_pot, int jump_distance);

using namespace std;

int main()
{
	int N, D;
	cin >> N >> D;
	Graph *graph = new Graph;
	creat_Graph(graph, N, D);
	if (save007(graph))
		cout << "Yes";
	else
		cout << "No";

    return 0; 
}

void creat_Graph(Graph *graph, int num_v, int distance)
{
	graph->Nv = num_v;
	graph->JP_distance = distance;
	graph->point = new Point[num_v];
	for (int i = 0; i < num_v; i++)
		cin >> graph->point[i].x >> graph->point[i].y;
}

bool save007(Graph *graph)
{
	bool answer = 0;
	bool *visited = new bool[graph->Nv];
	for (int i = 0; i < graph->Nv; i++)
		visited[i] = 0;

	for (int i = 0; i < graph->Nv; i++)
	{
		if (visited[i] != 1 && FirstJump(graph->point[i], graph->JP_distance))
		{
			visited[i] = true;
			answer = DFS(graph, i, visited);
			if (answer) break;
		}
	}
	return answer;
}

bool DFS(Graph *graph, int start_index, bool visited[])
{
	bool answer = 0;
	visited[start_index] = 1;
	if (Is_safe(graph->point[start_index], graph->JP_distance)) answer = 1;
	for (int i = 0; i < graph->Nv; i++)
	{
		if (visited[i] != 1 && Jump(graph->point[start_index], graph->point[i], graph->JP_distance))
		{
			answer = DFS(graph, i, visited);
			if (answer) break;
		}
	}
	return answer;
}

bool FirstJump(Point first_pot, int jump_distance)
{
	if (sqrt(pow(first_pot.x, 2) + pow(first_pot.y, 2)) <= jump_distance + ISLAND_WADTH)
		return 1;
	else
		return 0;
}

bool Jump(Point start_pot, Point direction_pot, int jump_distance)
{
	if (sqrt(pow(direction_pot.x - start_pot.x, 2) + pow(direction_pot.y - start_pot.y, 2)) <= jump_distance)
		return 1;
	else
		return 0;
}

bool Is_safe(Point pot, int jump_distance)
{
	if (abs(pot.x) + jump_distance >= 50 || abs(pot.y) + jump_distance >= 50)
		return 1;
	else 
		return 0;
}