1. 程式人生 > >HDU 5187 zhx's contest 快速冪+快速乘

HDU 5187 zhx's contest 快速冪+快速乘

As one of the most powerful brushes, zhx is required to give his juniors nn problems.
zhx thinks the ithith problem's difficulty is ii. He wants to arrange these problems in a beautiful way.
zhx defines a sequence {ai}{ai} beautiful if there is an ii that matches two rules below:
1: a1..aia1..ai are monotone decreasing or monotone increasing.
2: ai..anai..an are monotone decreasing or monotone increasing.
He wants you to tell him that how many permutations of problems are there if the sequence of the problems' difficulty is beautiful.
zhx knows that the answer may be very huge, and you only need to tell him the answer module pp.

Input

Multiply test cases(less than 10001000). Seek EOFEOF as the end of the file.
For each case, there are two integers nn and pp separated by a space in a line. (1≤n,p≤10181≤n,p≤1018)

Output

For each test case, output a single line indicating the answer.

Sample Input

2 233
3 5

Sample Output

2
1


        
 

Hint

In the first case, both sequence {1, 2} and {2, 1} are legal.
In the second case, sequence {1, 2, 3}, {1, 3, 2}, {2, 1, 3}, {2, 3, 1}, {3, 1, 2}, {3, 2, 1} are legal, so the answer is 6 mod 5 = 1
        

算到第四項的時候發現了規律:(2^n-2)%p;

然後用快速冪做,然後WA;

搜了下題解,發現還有快速乘這種東西,跟快速冪基本一樣,只是改成加號....

還有當n=1時,ans=0;

程式碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long ll;
ll n,p;
ll Mul (ll a,ll b)
{
   ll sum=0;
   while (b)
   {
       if(b&1)
       {
           sum=(sum+a)%p;
       }
       a=(a+a)%p;
       b>>=1;
   }
   return sum;
}
ll Fast (ll a,ll b)
{
    ll sum=1;
    while (b)
    {
        if(b&1)
        {
            sum=Mul(sum,a)%p;
        }
        a=Mul(a,a)%p;
        b>>=1;
    }
    return sum;
}
int main()
{
    while (scanf("%lld%lld",&n,&p)!=EOF)
    {
        if(n==1)
            printf("0\n");
        else
        {
            ll ans=(Fast(2,n)-2+p)%p;
            printf("%lld\n" ,ans);
        }
    }
    return 0;
}