1. 程式人生 > >【MST最小生成樹】

【MST最小生成樹】

還是暢通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 55870    Accepted Submission(s): 25344


Problem Description某省調查鄉村交通狀況,得到的統計表中列出了任意兩村莊間的距離。省政府“暢通工程”的目標是使全省任何兩個村莊間都可以實現公路交通(但不一定有直接的公路相連,只要能間接通過公路可達即可),並要求鋪設的公路總長度為最小。請計算最小的公路總長度。

Input測試輸入包含若干測試用例。每個測試用例的第1行給出村莊數目N ( < 100 );隨後的N(N-1)/2行對應村莊間的距離,每行給出一對正整數,分別是兩個村莊的編號,以及此兩村莊間的距離。為簡單起見,村莊從1到N編號。
當N為0時,輸入結束,該用例不被處理。

Output對每個測試用例,在1行裡輸出最小的公路總長度。

Sample Input3 1 2 1 1 3 2 2 3 4 4 1 2 1 1 3 4 1 4 1 2 3 3 2 4 2 3 4 5 0
Sample Output3 5 Hint
Hint Huge input, scanf is recommended.
Source
Recommend

JGShining   |   We have carefully selected several similar problems for you:  1102 1875 1879 1301 1162 

樓主準備了一週的考試...週一剛考完...

本題是最經典的最小生成樹MST

程式碼框架:

findRoot()

Edge結構體

初始化Tree

edges排序,cost從小到大

根據是否屬於同一集合確定是否是MST中的邊

程式碼:

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
#define NMAX 101
int Tree[NMAX];
int N;
int findRoot(int x){
	if(Tree[x]==-1)
		return x;
	int tmp=findRoot(Tree[x]);
	Tree[x]=tmp;
	return tmp;
}
struct Edge{
	int a,b;
	int cost;
	bool operator <(const Edge &e){
		return cost<e.cost;
	}
}edges[6000];
int main(){
	scanf("%d",&N);
	while(N!=0){
		for(int i=0;i<N*(N-1)/2;i++){
			scanf("%d %d %d",&edges[i].a,&edges[i].b,&edges[i].cost);
		}
		sort(edges,edges+N*(N-1)/2);
		memset(Tree,-1,sizeof(Tree));
		int tolcost=0;
		for(int i=0;i<N*(N-1)/2;i++){
			int fa=findRoot(edges[i].a);
			int fb=findRoot(edges[i].b);
			if(fa!=fb){
				Tree[fa]=fb;
				tolcost+=edges[i].cost;
			}
		}
		printf("%d\n",tolcost);
		scanf("%d",&N);
	}
}