1. 程式人生 > >HDU 1171.Big Event in HDU【01揹包】【5月26】

HDU 1171.Big Event in HDU【01揹包】【5月26】

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34498    Accepted Submission(s): 11964


Problem Description Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input 2 10 1 20 1 3 10 1 20 2 30 1 -1
Sample Output 20 10 40 40 將價值當作揹包容量,取價值總和的一半做揹包。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 250005;
int val[MAX], DP[MAX];
int N, v, m, l, sum;
int main()
{
    while(scanf("%d", &N) != EOF)
    {
        if(N < 1) break;
        memset(DP, 0, sizeof(DP));
        sum = l = 0;
        while(N--)
        {
            scanf("%d %d", &v, &m);
            sum += v*m;
            while(m--) val[l++] = v;
        }
        for(int i = 0;i < l; ++i)
        for(int j = sum/2;j >= val[i]; --j)
            DP[j] = max(DP[j], DP[j-val[i]]+val[i]);
        cout << sum-DP[sum/2] <<" "<< DP[sum/2] << endl;
    }
    return 0;
}