1. 程式人生 > >Big Event in HDU 多重背包

Big Event in HDU 多重背包

scan sof into time i++ 多個 cor nbsp days

B - Big Event in HDU

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don‘t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds). Input Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
Output For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
Sample Input
2
10 1
20 1
3
10 1 
20 2
30 1
-1
Sample Output
20 10
40 40


多重背包問題,可以將問題轉化成01背包。兩種思路:將多個相同物品拆分成一個一個價值相同的不同物品;也可以在01背包遞推時加一層物品個數的循環。
註意這題的坑點!是以一個負整數作為結束,不要想當然以為是-1。因為這個TLE了好久。。以後要認真讀題
ps:negative integer負整數 positive integer正整數

//第一種寫法,耗時1248ms
#include<stdio.h>
#include<string.h>

int
f[250005],a[10005]; int max(int x,int y) { return x>y?x:y; } int main() { int n,V,sum,c,x,y,i,j; while(scanf("%d",&n)&&n>=0){ memset(f,0,sizeof(f)); memset(a,0,sizeof(a)); sum=0;c=0; for(i=1;i<=n;i++){ scanf("%d%d",&x,&y); while(y--){ a[++c]=x; sum+=x; } } V=sum/2; for(i=1;i<=c;i++){ for(j=V;j>=a[i];j--){ f[j]=max(f[j],f[j-a[i]]+a[i]); } } printf("%d %d\n",sum-f[V],f[V]); } return 0; }
//第二種寫法,耗時811ms
#include<stdio.h>
#include<string.h>

int f[250005],a[1005],b[1005];

int max(int x,int y)
{
    return x>y?x:y;
}

int main()
{
    int n,V,sum,i,j,k;
    while(scanf("%d",&n)&&n>=0){
        memset(f,0,sizeof(f));
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        sum=0;
        for(i=1;i<=n;i++){
            scanf("%d%d",&a[i],&b[i]);
            sum+=a[i]*b[i];
        }
        V=sum/2;
        for(i=1;i<=n;i++){
            for(k=1;k<=b[i];k++){
                for(j=V;j>=0;j--){
                    if(j-a[i]>=0){
                        f[j]=max(f[j],f[j-a[i]]+a[i]);
                    }
                }
            }
        }
        printf("%d %d\n",sum-f[V],f[V]);
    }
    return 0;
}

Big Event in HDU 多重背包