1. 程式人生 > >Prim演算法和Kruskal演算法理解

Prim演算法和Kruskal演算法理解

一:Prim演算法

Prim演算法的實現就是通過搜尋來實現的,首先找一個起始點a,然後找與起始點相關聯的所有的點中離a最近的點b,並且把這個點融入最小生成樹中,然後再比較與b相關聯的點和與a相關聯的點的距離,若可以更新點,則更新然後繼續找!

拿一道poj的題來說

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area. 
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal. Input The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line. 
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i. 
Output For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network. Sample Input
1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0
Sample Output
0
17
16
26
這個題就可一用到prim演算法:程式碼如下
#include <iostream>
#include <vector>
#include<cstring> 
#include<cstdio> 
using namespace std;
const int maxn = 100 ;
const int INF = 0x3f3f3f3f;
int a , b , m ;
struct ac {
    int end , dis ;
};
int flag [ maxn ] ;///標記 
int dis[maxn]; 	//到生成樹的距離 
vector<ac> q[maxn];//結構體存的是每個資料的重點和距離,可能多個 
int prim ( int i ){
    int res= 0 ;//最小值 
    memset(flag, 0, sizeof(flag));
    memset(dis, INF, sizeof(dis));//初始化陣列 
    dis[i]=0;//記錄i到生成樹的距離 
    for ( int i = 0 ; i < a ; i ++ ) {//開始迴圈遍歷了 
        int u = -1 , min = INF ;//用u來記錄點的變化,min找最小值 
        for ( int j = 1 ; j <= a ; j ++ ) {//21-26找下一個離生成樹最近的點 
            if ( !flag[j] && dis [ j ] < min ) {
                u = j ;
                min = dis [ u ]; 
            }
        }
        res += min ;//求和 
        flag[u]=1;//標記 
        //更新點到樹的距離 ,q[u]相當於一個結構體陣列 
        for ( int i = 0 ; i < q[u].size(); i ++ ) {
            int v = q[u][i].end;//v表示所有相鄰的點 
            if ( !flag[v]&& q[u][i].dis<dis[v]){//看能不能更換距離 
                dis[v]=q[u][i].dis ;
            }
        }
    }
    return res ;
}
int main()
{
    while (scanf("%d" , &a ) , a) {
        cin >> m ;
        b = m ;
        while ( b -- ) {
            ac p ;
            int a ;
            cin >> a ;
            cin >>p.end>>p.dis;
            q[a].push_back(p);//無向圖,要存兩遍 
            int t = p.end ;
            p.end=a;
            q[t].push_back(p);
        }
        char x , y ;
        scanf ( "%c%c" ,&x ,&y ) ;
        int t = prim ( 1 ) ;//開始遍歷 
        cout << t<<endl;
        for( int i= 1 ; i <= a ; i ++ ) {
        	q[i].clear();
		}
    }
    return 0;
}
當然也可以用Kruska

程式碼如下

#include <iostream>
#include <algorithm>
#include<cstdio>
#include<cstdio>
using namespace std;
const int maxn = 110 ;
struct ac {
    int begin ;
    int end ;
    int jl ;
};
ac q[1000];
int fa[maxn];
int k ;
int find ( int x )
{
    int r = x ;
    while ( r != fa[r] ) {
        r = fa[ r ];
    }
    return r ;
}
void join ( int x , int y ) {
    int xx = find ( x ) , yy = find ( y ) ;
    if ( xx != yy ) {
        fa [xx] = yy ;
    }
}
bool cmp ( ac a , ac b ) {
    return a.jl < b.jl ;
}
int ans ;
void kus(){
    sort ( q , q + k , cmp ) ;
    for ( int i = 0 ; i < k ; i ++ ) {
        if  ( find(q[i].begin) != find ( q[i].end )){
            join ( q[i].begin , q[i].end );
            ans += q[i].jl;

        }
    }
    cout << ans << endl;
}
int main ()
{
    int n ;
    while ( scanf("%d" , &n ) , n ) {
        k = 0 ;
        memset(q, 0, sizeof(q));
        while ( n -- ) {
            int a , b , c ;
		    cin >> a >> b >> c ;
            q[k].begin=a;
            q[k].end=b;
            q[k].jl=c;
            k ++ ;
        }
        for ( int i = 1 ; i <= n ; i ++ ) {
            fa[i]=i ;
        }
        ans = 0 ;
        kus();
    }
    return 0;
}