1. 程式人生 > >HDU1796 How many integers can you find (容斥原理)

HDU1796 How many integers can you find (容斥原理)

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6961 Accepted Submission(s): 2050

Problem Description
Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input
There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0< N<2^31,0< M<=10, and the M integer are non-negative and won’t exceed 20.

Output
For each case, output the number.

Sample Input
12 2
2 3

Sample Output
7

Author
wangye

Source
2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(4)

Recommend
wangye | We have carefully selected several similar problems for you: 1793 1794 1797 1795 1798

容斥原理水題然後要判0,因為0會導致除0錯誤。資料範圍裡面明明說每個數都是大於0的,還要我判0,簡直莫名其妙。

#include <cstring>
#include <cstdio>
#include <iostream>
#include <string.h>
using namespace std;

long long num[15],n,cnt;
long long ans=0;
long long gcd(long long a,long long b)
{
    long long t;
    while(b)
    {
        t=a%b;
        a=b;
        b=t;
    }
    return a;
}


void dfs(int now_cur,int set_cnt,long long lcm)
{
    //printf("%lld %lld %lld\n",num[now_cur],lcm,gcd(num[now_cur],lcm));
    lcm=num[now_cur]*lcm/gcd(num[now_cur],lcm);
    if(set_cnt%2==1)
        ans+=(n-1)/lcm;
    else
        ans-=(n-1)/lcm;
    for(int i=now_cur+1;i<=cnt;i++)
        dfs(i,set_cnt+1,lcm);
}

int main()
{
    while(~scanf("%lld%lld",&n,&cnt))
    {
        ans=0;
        int mark=1;
        for(int i=1;i<=cnt;i++)
        {
            scanf("%lld",&num[mark]);
            if(num[i])
                mark++;
        }
        cnt=mark-1;
        for(int i=1;i<=cnt;i++)
            dfs(i,1,1);
        printf("%lld\n",ans);
    }
}