1. 程式人生 > >1796 How many integers can you find

1796 How many integers can you find

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10302    Accepted Submission(s): 3078


 

Problem Description

  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

 

Input

  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

 

Output

  For each case, output the number.

 

Sample Input

12 2 2 3

 

Sample Output

7

 

Author

wangye

題意:

給定數n和有m個數的集合

問1-n中有多少數能被集合裡的某個數整除

思路:

直接進行容斥有10層會T,要進行二進位制優化,即用數的二進位制來表示數組裡取的和沒取的數,再根據取數個數的奇偶來判斷是要加還是減

注意要在輸入數時要把0去掉...

#include <bits/stdc++.h>
using namespace std;
#define ll long long
ll n;
int m;
int num[20];
int main()
{
	while(scanf("%lld%d",&n,&m)!=EOF)
	{
		n--;
		int pl=0;
		for(int i=1;i<=m;i++)
		{
			scanf("%d",&num[pl]);
			if(num[pl])
			pl++;
		}
		ll ans=0;
		for(int i=1;i<(1<<pl);i++)
		{
			int cnt=0;
			ll sum=1;
			for(int j=0;j<pl;j++)
			{
				if(i&(1<<j))
				{
					cnt++;
					sum=(num[j]/__gcd(sum,(ll)num[j])*sum);
				}
			}
			if(cnt&1)
			ans+=n/sum;
			else
			ans-=n/sum;
		}
		printf("%lld\n",ans);
	}
}