1. 程式人生 > >PAT (Advanced Level) Practice 1027 Colors in Mars (20 分)(C++)(甲級)(兩種方法)

PAT (Advanced Level) Practice 1027 Colors in Mars (20 分)(C++)(甲級)(兩種方法)

1027 Colors in Mars (20 分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71
Sample Output:

#123456


#include <cstdio>
#include <cstring>
#include <cmath>

int main()
{
	int R = 0, G = 0, B = 0;
	scanf("%d %d %d", &R, &G, &B);
	char S[15] = { '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'A', 'B', 'C' };//查詢表
	printf
("#%c%c", S[R / 13], S[R % 13]);//第一次記得輸出# printf("%c%c", S[G / 13], S[G % 13]); printf("%c%c", S[B / 13], S[B % 13]); return 0; }

#include <cstdio>
#include <cstring>
#include <cmath>

int main()
{
	int R = 0, G = 0, B = 0;
	scanf("%d %d %d", &R, &G, &B);
	char S[10] = { 0 };//輔助棧
	int top = -1, temp = 0;//temp用來儲存餘數部分
	for (int i = 0; i < 2; i++)//RGB逆序進行
	{
		temp = B % 13;
		B /= 13;
		S[++top] = temp <= 9 ? temp + '0' : temp - 10 + 'A';//注意S為字元棧
	}
	for (int i = 0; i < 2; i++)
	{
		temp = G % 13;
		G /= 13;
		S[++top] = temp <= 9 ? temp + '0' : temp - 10 + 'A' ;
	}
	for(int i=0; i<2; i++)
	{
		temp = R % 13;
		R /= 13;
		S[++top] = temp <= 9 ? temp + '0' : temp - 10 + 'A';
	}
	printf("#");//列印#和棧即可
	while (top >= 0) printf("%c", S[top--]);
	return 0;
}