1. 程式人生 > >GCC(階乘和求餘,很重要)

GCC(階乘和求餘,很重要)

GCC

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 4162    Accepted Submission(s): 1365


Problem Description The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m

Input The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.

Output Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000

Sample Input 1 10 861017
Sample Output 593846
Source 階乘和求餘,見過快速冪求餘,見過階乘求餘,沒見過階乘和求
餘,公式我也看不懂!就知道前面,如果stl>=7就說明n是一個非 大的數的一個因子,當這個數大於n時,其餘數為0!所以要求 n以及n以下的階乘和
#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
using namespace std;
int main()
{
    long long ans,sum,f;
    int t,stl,n,i;
    char c[500];
    cin>>t;
    while(t--)
    {
        cin>>c>>n;
        stl=strlen(c);
        if(stl>=7)
        {
            ans=n;
        }
        else
        {
            ans=0;
            for(i=0;i<stl;i++)
            {
                ans=ans*10+(c[i]-'0');
            }
        }
        for(f=i=1,sum=0;i<=ans;i++)
        {
            f=f*i%n;
            sum=(sum+f)%n;
        }
        sum=(sum+1)%n;
        cout<<sum<<endl;
    }
}