1. 程式人生 > >POJ 2437 Muddy Roads(貪心 最少固長線段覆蓋區間)

POJ 2437 Muddy Roads(貪心 最少固長線段覆蓋區間)

Language:
Muddy roads
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3389 Accepted: 1557
Description

Farmer John has a problem: the dirt road from his farm to town has suffered in the recent rainstorms and now contains (1 <= N <= 10,000) mud pools.

Farmer John has a collection of wooden planks of length L that he can use to bridge these mud pools. He can overlap planks and the ends do not need to be anchored on the ground. However, he must cover each pool completely.

Given the mud pools, help FJ figure out the minimum number of planks he needs in order to completely cover all the mud pools.
Input

  • Line 1: Two space-separated integers: N and L

  • Lines 2..N+1: Line i+1 contains two space-separated integers: s_i and e_i (0 <= s_i < e_i <= 1,000,000,000) that specify the start and end points of a mud pool along the road. The mud pools will not overlap. These numbers specify points, so a mud pool from 35 to 39 can be covered by a single board of length 4. Mud pools at (3,6) and (6,9) are not considered to overlap.
    Output

  • Line 1: The miminum number of planks FJ needs to use.
    Sample Input

3 3
1 6
13 17
8 12
Sample Output

5
Hint

INPUT DETAILS:

FJ needs to use planks of length 3 to cover 3 mud pools. The mud pools cover regions 1 to 6, 8 to 12, and 13 to 17.

OUTPUT DETAILS:

FJ can cover the mud pools with five planks of length 3 in the following way:
111222..333444555….

               .MMMMM..MMMM.MMMM....

               012345678901234567890

Source

USACO 2005 U S Open Silver

題意:n個區間,給出每個區間的起始點,注意是左閉右開的,問最少用多少長為l的線段能覆蓋掉這n個區間

做法:以每個區間的左端點排序,以tmp記錄下當前覆蓋區間的右端點(開),看下一個區間的端點和tmp的大小關係就好了
如b小於tmp就說明這個區間已經被覆蓋了,b>=tmp 時, 再看a,如果a>tmp說明這個區間還有一部分沒有被覆蓋,把a賦值為tmp-1(因為a為閉,tmp是開)
a<=tmp時就重新計算一下區間需要用的線段更新最右端

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <stack>
#include <vector>
#define maxn 10010
#define maxe 100010
typedef long long ll;
using namespace std;
const double eps=1e-5;
const int inf=0x3f3f3f3f3f;
struct Node
{
    int a,b;
}node[maxn];
int cal(int a,int b,int l)
{
    if((b-a)%l==0)return (b-a)/l;
    else return (b-a)/l+1;
}
bool cmp(Node x,Node y)
{
    return x.a<y.a;
}
int main()
{
    int n,l;
   // freopen("in.txt","r",stdin);
    while(scanf("%d%d",&n,&l)==2)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&node[i].a,&node[i].b);
        }
        sort(node,node+n,cmp);
        int tmp=node[0].b;
        int ans=cal(node[0].a,node[0].b,l);
        int q=ans*l+node[0].a;
        int p=0;
        tmp=max(tmp,q+1);
        for(int i=1;i<n;i++)
        {
            if(node[i].b<tmp)continue;
            if(node[i].a<tmp)
            {
                node[i].a=tmp-1;
                p=cal(node[i].a,node[i].b,l);
                ans+=p;
                q=node[i].a+l*p+1;
                tmp=q;
            }
            else
            {
                p=cal(node[i].a,node[i].b,l);
                ans+=p;
                tmp=max(node[i].b,node[i].a+p*l+1);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}