1. 程式人生 > >hdoj 1002 A + B Problem II 【大數A+B】

hdoj 1002 A + B Problem II 【大數A+B】

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 308540    Accepted Submission(s): 59647


Problem Description I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input 2 1 2 112233445566778899 998877665544332211
Sample Output Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110題解:大數相加,將兩個字串反轉 (s1[i]-'0' s2[i]-'0'),存於a[] b[],然後逐位相加,判斷進位,倒序輸出!!!注意格式!!!
#include <cstdio>
#include <cstring>
#include <cmath>
char s1[1010],s2[1010];
int a[1010],b[1010],c[1010];
int max(int a,int b)
{
    if(a>b)
        return a;
    else
        return b;
}
int main()
{
    int t,k=1;
    scanf("%d",&t);
    while(t--)
    {

        scanf("%s%s",s1,s2);
        printf("Case %d:\n",k++);
        printf("%s + %s = ",s1,s2);
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        int la=strlen(s1);
        int lb=strlen(s2);
        int ans=0,cnt=0;
        for(int i=la-1;i>=0;i--)
        {
            a[ans]=s1[i]-'0';//字串反轉
            ans++;
        }
        for(int i=lb-1;i>=0;i--)
        {
            b[cnt]=s2[i]-'0';
            cnt++;
        }
        int maxn;
        maxn=max(la,lb);
        for(int i=0;i<=maxn-1;i++)//從左到右逐位相加
        {
        	a[i]=a[i]+b[i];//將各位之和還賦給陣列a[] 
			if(a[i]>=10)//考慮各位之和大於等於10的情況,考慮進位 
			{
				a[i]-=10;
				a[i+1]++;		
			}        
        }        
        if(a[maxn]==0)//判斷最後一位是否有進位 
        {
        	for(int i=maxn-1;i>=0;i--)        	
        		printf("%d",a[i]);			
		}
		else
		{
			for(int i=maxn;i>=0;i--)
				printf("%d",a[i]);							
		}
        if(t==0) 
            printf("\n");
        else
            printf("\n\n");//每行輸出間有空格 
    }
    return 0;
}


再附上一個屬於我的!用c[] 儲存結果
#include <cstdio>
#include <cmath>
#include <cstring> 
char s1[1010],s2[1010];
int a[1010],b[1010],c[1010];
int max(int a,int b)
{
	if(a>b)
		return a;
	else
		return b;
}
int main()
{
	int t,k=0;
	scanf("%d",&t);
	while(t--)
	{
		
		scanf("%s%s",s1,s2);
		printf("Case %d:\n",k++);
		printf("%s + %s = ",s1,s2);
		memset(a,0,sizeof(a));//清零!!! 
		memset(b,0,sizeof(b));//清零 !!! 
		memset(c,0,sizeof(c));//清零!!! 
		int la,lb;
		la=strlen(s1);
		lb=strlen(s2);
		int ans=0,cnt=0;
		for(int i=la-1;i>=0;i--)
		{
			a[ans]=s1[i]-'0';	
			ans++;
		}		
			
		for(int i=lb-1;i>=0;i--)
		{
			b[cnt]=s2[i]-'0';
			cnt++;
		}		
		int maxn=max(la,lb);
		for(int i=0;i<=maxn-1;i++)
		{
			if((c[i]+a[i]+b[i])>=10)
				c[i+1]++;
			c[i]=(c[i]+a[i]+b[i])%10;
		}					
		if(c[maxn]==0)
		{
			for(int i=maxn-1;i>=0;i--)
		 		printf("%d",c[i]);
		 } 
		 else
		 {
		 	for(int i=maxn;i>=0;i--)			
				printf("%d",c[i]);	
		 }
		 if(t==0)
		 	printf("\n");
		else
			printf("\n\n");
	}
	return 0;
 }