1. 程式人生 > >1002 1002 A + B Problem II大數相加

1002 1002 A + B Problem II大數相加

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 317528    Accepted Submission(s): 61692


Problem Description I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input 2 1 2 112233445566778899 998877665544332211
Sample Output Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
Author

Ignatius.L

大數相加思路非常簡單,只要用陣列將大數的每一位都存起來,注意進位。。。。。

AC程式碼:

#include<stdio.h>
#include<string.h>
#define Max 101
void print(char sum[]);
void bigNumAdd(char a[],char b[],char sum[]);
int main()
{
	char a[Max];
	char b[Max];
	char sum[Max];
	gets(a);
	gets(b);
	bigNumAdd(a,b,sum);
	print(sum);
	return 0;
}

void bigNumAdd(char a[],char b[],char sum[])
{
	int i=0;
	int c=0;//表示進位
          //初始化,對以後位運算有很大幫助!
	char m[Max]={0};
	char n[Max]={0};
	memset(sum,0,Max*sizeof(char)); //這裡不能寫成memset(sum,0,sizeof(sum));原因見注意事項1
	//字串反轉且字串變數字
	int lenA=strlen(a);
	int lenB=strlen(b);
	for (i=0;i<lenA;i++)
	{
		m[i]=a[lenA-i-1]-'0';
	}
	for (i=0;i<lenB;i++)
	{
		n[i]=b[lenB-i-1]-'0';
	}
	//位運算
	for (i=0;i<lenA||i<lenB;i++)
	{
		sum[i]=(m[i]+n[i]+c)%10+'0';//得到末位
		c=(m[i]+n[i]+c)/10;//得到進位
	}
}

void print(char sum[])
{
	int i=0;
	int j=0;
	int len = strlen(sum);
	for (i=len-1;sum[i]==0;i--); //找到第一個不為零的位置,方便輸出
	for (j=i;j>=0;j--)
	{
		printf("%c",sum[j]);
	}
}