1. 程式人生 > >hdu1006Biorhythms(中國剩餘定理)

hdu1006Biorhythms(中國剩餘定理)

Description

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak. 

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form: 

Case 1: the next triple peak occurs in 1234 days. 

Use the plural form ``days'' even if the answer is 1.

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

題意:自出生起就有體力,情感和智力三個生理週期,分別為23,28和33天。一個週期內有一天為峰值,在這一

     天,人在對應的方面(體力,情感或智力)表現最好。通常這三個週期的峰值不會是同一天。現在給出三個日

     期,分別對應於體力,情感,智力出現峰值的日期。然後再給出一個起始日期,要求從這一天開始,算出最少

     再過多少天后三個峰值同時出現。

感覺好像就是一道比較裸的中國剩餘定理,注意如果出現的天數小於當天的日期,要加上21252.

AC程式碼:

Source Code

Problem: 1006		User: yzk_accepted
Memory: 164K		Time: 47MS
Language: C++		Result: Accepted
Source Code
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
typedef long double ldb;
ll a[4],m[4];
void extend_Euclide(ll a,ll b,ll &x,ll &y){
	if(b==0){
		x=1;
		y=0;
		return;
	}
	extend_Euclide(b,a%b,x,y);
	int tmp=x;
	x=y;
	y=tmp-(a/b)*y;
}
ll CRT(){
	ll M = 1;  
    ll ans = 0;  
    for(int i=0; i<3; i++)  
        M *= m[i];  
    for(int i=0; i<3; i++)  
    {  
        ll x, y;  
        ll Mi = M / m[i];  
        extend_Euclide(Mi, m[i], x, y);  
        ans = (ans + Mi * x * a[i]) % M;  
    }  
    if(ans < 0) ans += M;  
    return ans;  
}

int main()
{
	int p,e,i,d,icas=1;
	m[0]=23,m[1]=28,m[2]=33;
    while(~scanf("%d%d%d%d",&p,&e,&i,&d)){
    	if(p==-1 && e==-1&&e==-1 && d==-1)
    		break;
   		a[0]=p,a[1]=e,a[2]=i;
   		ll k=CRT();
   		if(k==0)	k=21252;
   		if(k<=d)	k=k+21252;
   		d=k-d;
   		printf("Case %d: the next triple peak occurs in %d days.\n",icas++,d);
    }
    return 0;
}