1. 程式人生 > >POJ 2318 TOYS (向量叉乘+二分)

POJ 2318 TOYS (向量叉乘+二分)

TOYS
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16287 Accepted: 7821

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

題意是給定一個矩形的兩點,裡面有n條線段,線段不相交而且線段嚴格從左到右排列,把矩形分成了n-1個區域,給定m個點,問每一個區域內有幾個點。

聽說暴力也可以過,畢竟給了2s。這個題屬於基礎幾何題,由於給定的直線只有端點,所以,要把端點跟開始給的左右起點聯絡起來,建立新的座標點。將每個點與直線的端點做向量,小於0代表點在直線左邊,大於0代表點在 直線右邊。然後二分去查詢點所在的區域,最後記錄。

程式碼實現:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<cstdio>
#define ll int
#define mset(a,x) memset(a,x,sizeof(a))

using namespace std;
const double PI=acos(-1);
const int inf=0x3f3f3f3f;
const double esp=1e-6;
const int maxn=5e3+5;
const int mod=1e9+7;
int dir[4][2]={0,1,1,0,0,-1,-1,0};
int n,m,x1,x2,Y1,y2,ans[maxn];
struct point{
	int x,y;
	point(){};                               //因為有帶參的建構函式,下面無法直接定義,所以加一個無參的建構函式 
	point(int newx,int newy)                 //需要過載-,所以設立一個帶參的建構函式 
    {  
        x=newx;y=newy;  
    }  
	point operator -(const point &b)        //兩點相減得到向量,故過載一下- 
	{
		return point(x-b.x,y-b.y);
	}
}LL[maxn],rr[maxn];                         //ll記錄線段第一個端點,rr記錄第二個 

int cross(point a,point b)                  //求向量叉乘 
{
	return a.x*b.y-b.x*a.y;
}

int main()
{
	int x,y,i,j,k;
	while(cin>>n&&n)
	{
		cin>>m>>x1>>Y1>>x2>>y2;
		mset(ans,0);
		for(i=0;i<n;i++)                  //將直線端點構造成點 
		{
			cin>>x>>y;
			LL[i].x=x;
			LL[i].y=Y1;
			rr[i].x=y;
			rr[i].y=y2;
		}
		for(i=0;i<m;i++)
		{
			point p;
			cin>>p.x>>p.y;
			int l=0,r=n,temp=n;          //temp記錄查詢到的n的值 
			while(l<=r)
			{
				int mid=(l+r)/2;
				if(cross(p-rr[mid],LL[mid]-rr[mid])<=0)   //叉乘小於0,點線上的左邊 
				{
					temp=mid;
					r=mid-1;
				}
				else                                      //叉乘大於0,點線上的右邊 
				l=mid+1;	
			}
			ans[temp]++;                                  //記錄點的位置 
		}
		for(i=0;i<=n;i++)
		{
			printf("%d: %d\n",i,ans[i]); 
		}
		cout<<endl;                                       //注意最後空行 
	}
	return 0;
}