1. 程式人生 > >[PAT甲級] 1002 A+B for Polynomials (25)

[PAT甲級] 1002 A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

一個使用額外O(1)空間並且時間複雜度為O(N1)的簡單解如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
    float poly[1000] = {0.0};
    int n, expo, maxE = 0;
    float coeff;
    cin >> n;
    for (int i = 0; i < n; i ++)
    {
        cin >> expo >> coeff;
        poly[expo] += coeff;
        if (maxE < expo) maxE = expo;
    }
    cin >> n;
    for (int i = 0; i < n; i ++)
    {
        cin >> expo >> coeff;
        poly[expo] += coeff;
        if (maxE < expo) maxE = expo;

    }
    n = 0;
    for (int i = 0; i <= maxE; i ++)
    {
        if (poly[i] != 0) n ++;
    }
    cout << n;
    if (n != 0) cout << " ";
    for (int i = maxE; i >= 0; i --)
    {
        if (poly[i] != 0.0)
        {
            n --;
            printf("%d %.1f", i, poly[i]);
            //cout << i << " " << poly[i];
            if(n != 0) cout << " ";
        }
    }
    return 0;
}