1. 程式人生 > >杭電oj(Java版)—— 2602 Bone Collector—— 01揹包問題

杭電oj(Java版)—— 2602 Bone Collector—— 01揹包問題

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 59998    Accepted Submission(s): 25024


Problem Description Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?


Input The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output One integer per line representing the maximum of the total value (this number will be less than 231
).
Sample Input 1 5 10 1 2 3 4 5 5 4 3 2 1
Sample Output 14
import java.util.Scanner;

public class Main{
	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		int n = scanner.nextInt();
		
		for (int i=0;i<n;i++) {
			int a = scanner.nextInt();
			int v[] = new int[a];	//重量
			int w[] = new int[a];	//價值
			int W = scanner.nextInt();	//包能容納的總重量
			
			long dp[] = new long[1005];

			for (int j=0;j<a;j++) {
				w[j] = scanner.nextInt();
			}
			for (int j=0;j<a;j++) {
				v[j] = scanner.nextInt();
			}
			
			for (int j=0;j<a;j++) {
				for (int k=W;k>=0;k--) {
					if (v[j]<=k) {
						dp[k] = Math.max(dp[k], dp[k-v[j]]+w[j]);						
					}
				}
			}
			
			System.out.println(dp[W]);
		}
	}
}