1. 程式人生 > >POJ 2823 Sliding Window (單調佇列)@

POJ 2823 Sliding Window (單調佇列)@

An array of size n ≤ 10 6 is given to you. There is a sliding window of size kwhich is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k
 is 3.
Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 
Output There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 
Sample Input
8 3
1 3 -1 -3 5 3 6 7
Sample Output
-1 -3 -3 -3 3 3
3 3 5 5 6 7

給定一個數組,和區間長度,求從起點開始遍歷,求當前區間的最值

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
typedef long long LL;
const int N = 1e6+100;
const int mod = 1e9+7;
int a[N], b[N], c[N], deq1[N], deq2[N], tail1[N], tail2[N];


int main()
{
    int n, k;
    scanf("%d %d", &n, &k);

    for(int i=0; i<n; i++) scanf("%d", &a[i]);
    int s1=0, t1=0, s2=0, t2=0;
    for(int i=0; i<n; i++)
    {
        while(s1<t1&&deq1[t1-1]>=a[i]) t1--;
        while(s2<t2&&deq2[t2-1]<=a[i]) t2--;
        tail1[t1]=i, tail2[t2]=i;
        deq1[t1++]=a[i], deq2[t2++]=a[i];
        if(i-k+1>=0)
        {
            while(tail1[s1]<i-k+1) s1++;
            while(tail2[s2]<i-k+1) s2++;
            b[i-k+1]=deq1[s1];

            c[i-k+1]=deq2[s2];

        }
    }
    for(int i=0; i+k<=n; i++)
    {
        if(i==0) printf("%d",b[i]);
        else printf(" %d",b[i]);
    }
    printf("\n");
    for(int i=0; i+k<=n; i++)
    {
        if(i==0) printf("%d",c[i]);
        else printf(" %d",c[i]);
    }
    printf("\n");
    return 0;
}