1. 程式人生 > >Phone List (HDU_1671) 字典樹

Phone List (HDU_1671) 字典樹

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16031    Accepted Submission(s): 5404


Problem Description Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
Output For each test case, output “YES” if the list is consistent, or “NO” otherwise.
Sample Input 2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
Sample Output NO YES 題目大意:給出一組數字序列,判斷是否有序列為字首; 解題思路:字典樹。在構建字典樹的時候判斷是否存在字首: 情況1:判斷之前構建的序列是否為當前序列的字首,先假設其他序列不是字首(true),在構建路徑上一旦發現其他序列是字首,就修改為false;
for(int i = 0,id = 0;i < len;i ++){
		for(int j = 0;j < maxn;j ++){ //其他為字首 
			if(p -> flag == 1) f2 = false;
		}
情況2:判斷自身是否為字首,先假設自身是字首(false),在構建路徑上發現開闢新空間,即為非字首,修改為true;
if(p -> next[id] == NULL){
			f1 = true; //自身不為字首 
			p -> next[id] = newNode();
		}
注意:new開闢的空間在程式結束後需要delete,且root為靜態開闢的,不能delete; 程式碼如下:
#include"iostream"
#include"cstdio"
#include"cstring"
using namespace std;
const int maxn = 10;
struct node{
	node *next[maxn];	 
	int flag;
};
node root;	//定義根節點
//產生新節點
node *newNode(){
	node *temp = new node;
	for(int i = 0;i < maxn;i ++){
		temp -> next[i] = NULL;
	}
	temp -> flag = 0;
	return temp;
} 
//構建字典樹 
bool creat(char *str){
	bool f1 = false,f2 = true;
	int len = strlen(str);
	node *p = &root;
	for(int i = 0,id = 0;i < len;i ++){
		for(int j = 0;j < maxn;j ++){ //其他為字首 
			if(p -> flag == 1) f2 = false;
		}
		id = str[i] - '0';
		if(p -> next[id] == NULL){
			f1 = true; //自身不為字首 
			p -> next[id] = newNode();
		}
		p = p -> next[id];
	}
	p -> flag = 1;
	return f1&&f2;
}
//釋放記憶體 
int freedom(node *p){
    int i = 0;
    for(i = 0;i < maxn;i ++)
    if(p -> next[i] != NULL) freedom(p -> next[i]);
    if(p == &root){
    	for(int j = 0;j < maxn;j ++)
    		p -> next[j] = NULL;
    	p -> flag = 0;
	}else{
		delete(p);
	}
	return 0;
}
int main(){
	int T,n,f,tf;
	char str[15];
	scanf("%d",&T);
	while(T--){
		scanf("%d",&n);
		tf = true;
		for(int i = 0;i < n;i ++){
			scanf("%s",str);
			f = creat(str);
			if(f == false) tf = false;
		}
		if(tf) printf("YES\n");
		else printf("NO\n");
		//釋放記憶體
		freedom(&root);
	}
	return 0;
}