1. 程式人生 > >POJ2104 K-th Number —— 劃分樹(模板題)

POJ2104 K-th Number —— 劃分樹(模板題)

K-th Number
Time Limit: 20000MS Memory Limit: 65536K
Total Submissions: 59744 Accepted: 20847
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

Source


程式碼如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <string>
#include <set>
using namespace std;
typedef long long LL;
const int INF = 2e9;
const LL LNF = 9e18;
const int mod = 1e9+7;
const int MAXN = 1e5+10;

int tree[20][MAXN];
int sorted[MAXN];
int toleft[20][MAXN];

void build(int l, int r, int dep)
{
    if(l==r) return;
    int mid = (l+r)>>1;
    int same = mid-l+1;
    for(int i = l; i<=r; i++)
        if(tree[dep][i]<sorted[mid])
            same--;

    int lpos = l, rpos = mid+1;
    for(int i = l; i<=r; i++)
    {
        if(tree[dep][i]<sorted[mid])
            tree[dep+1][lpos++] = tree[dep][i];
        else if(tree[dep][i]==sorted[mid] && same>0)
        {
            tree[dep+1][lpos++] = tree[dep][i];
            same--;
        }
        else
            tree[dep+1][rpos++] = tree[dep][i];
        toleft[dep][i] = toleft[dep][l-1] + lpos - l;
    }

    build(l, mid, dep+1);
    build(mid+1, r, dep+1);
}

int query(int L, int R, int l, int r, int dep, int k)
{
    if(l==r) return tree[dep][l];
    int mid = (L+R)>>1;
    int cnt = toleft[dep][r] - toleft[dep][l-1];

    if(cnt>=k)
    {
        int newl = L + toleft[dep][l-1] - toleft[dep][L-1];
        int newr = newl + cnt - 1;
        return query(L, mid, newl, newr, dep+1, k);
    }
    else
    {
        int newr = r + toleft[dep][R] - toleft[dep][r];
        int newl = newr - (r-l-cnt);
        return query(mid+1, R, newl, newr, dep+1, k-cnt);
    }
}

int main()
{
    int n, m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(tree, 0, sizeof(tree));
        for(int i = 1; i<=n; i++)
        {
            scanf("%d",&tree[0][i]);
            sorted[i] = tree[0][i];
        }
        sort(sorted+1, sorted+1+n);
        build(1, n, 0);
        int s, t, k;
        while(m--)
        {
            scanf("%d%d%d",&s,&t,&k);
            printf("%d\n", query(1,n,s,t,0,k));
        }
    }
    return 0;
}