1. 程式人生 > >HDOJ 2058 The sum problem(數學問題)

HDOJ 2058 The sum problem(數學問題)

The sum problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8287    Accepted Submission(s): 2530


Problem Description Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
Input Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

Output For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

Sample Input 20 10 50 30 0 0
Sample Output [1,4] [10,10] [4,8] [6,9] [9,11] [30,30]

我本來的想法是考慮子列的起點和終點,分別以s和e表示,由等差數列求和公式有(s+e)*(e-s+1)/2==M(1式),化為e*(e+1)-s*(s-1)==2*M, so , e=(int)sqrt(2*M+s*(s-1)),將得到的e再代回1式,成立則[s,e]滿足條件。

但是,2*M+s*(s-1)太大……

後來參考網上的一個演算法,不考慮子列的終點,而是考慮子列的起點和子列元素的個數,分別記為i,j。由等差數列求和公式,得(i+(i+j-1))*j/2==M ,即(2*i+j-1)*j/2==M(2式),故得i=(2*M/j-j+1)/2,將i,j代回2式,成立則[i,i+j-1]滿足條件。注意j最小為1,而由2式,得(j+2*i)*j=2*M,而i>=1,故j*j<=(int)sqrt(2*M).

AC code:

#include <iostream>
#include <cmath>
using namespace std;
int main()
{
	int N,M,i,j;
	while(scanf("%d%d",&N,&M) && M+N)
	{ 
	 	for(j=pow(2.0*M,0.5);j>0;j--)
		{
			i=(2*M/j-j+1)/2;
			if(j*(j+2*i-1)/2==M) printf("[%d,%d]\n",i,i+j-1);
		}
		printf("\n");					  
 	} 	
	return 0;	
}