1. 程式人生 > >POJ 3617 Best Cow Line(貪心)

POJ 3617 Best Cow Line(貪心)

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

需要注意的是首末兩項相等的情況:此時應判斷首項的後一項與末項的前一項的大小關係,若flag1+1>flag2-1,則取末項;若flag1+1<flag2-1,則取前項;若相等,需要迴圈判斷

#include<iostream>
using namespace std;


int n;
char oldLine[2000];
char newLine[2000];

int equal(int flag1,int flag2)
{
	if (oldLine[flag1]>oldLine[flag2])
	{
		return 0;
	}
	else if (oldLine[flag1]<oldLine[flag2])
	{
		return 1;
	}

	else
	{
		equal(flag1+1, flag2-1);
	}

}

int main()
{
	cin>>n;
	for (int i = 0; i < n; i++)
	{

		cin >> oldLine[i];
	}

	int flag1 = 0;
	int flag2 = n-1;
	for (int i = 0; i < n; i++)
	{
		if (oldLine[flag1]>oldLine[flag2])
		{
			newLine[i] = oldLine[flag2];
			flag2--;
		}
		else if (oldLine[flag1]<oldLine[flag2])
		{
			newLine[i] = oldLine[flag1];
			flag1++;
		}
		else
		{
			equal(flag1, flag2);
			if (equal(flag1, flag2)==0)
			{
				newLine[i] = oldLine[flag2];
				flag2--;
			}
			else
			{
				newLine[i] = oldLine[flag1];
				flag1++;
			}
		}
	}

	for (int i = 0; i < n; i++)
	{
		cout << newLine[i];
		if ((i + 1) % 80 == 0)
		{
			cout << endl;
		}
	}


	return 0;

}