1. 程式人生 > >hdu 2138(米勒—拉賓素數測試)

hdu 2138(米勒—拉賓素數測試)

     How many prime numbers

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description   Give you a lot of positive integers, just to find out how many prime numbers there are.
Input   There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
Output   For each case, print the number of prime numbers you have found out.
Sample Input 3 2 3 4
Sample Output 2 解題思路:這道題目如果靠篩選法那肯定會超時。米勒—拉賓素數測試可以進行大素數判斷。。。 米勒—拉賓素數測試主要依靠兩個基本定理: 1)費馬小定理:當gcd(a,p)=1且p為素數時,有a^p-1 mod p = 1 2)快速冪取模演算法(RSA公鑰加密演算法) 其實這個演算法模板我也沒有很明白,先湊合著看吧。。。 AC:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

__int64 qpow(int a,int b,int r)
{
	__int64 ans = 1,buff = a;
	while(b)
	{
		if(b & 1)
			ans = (ans*buff) % r;
		buff = (buff*buff) % r;
		b >>= 1;
	}
	return ans;
}

bool Miller_Rabbin(int n,int a)
{
	int r = 0,s = n-1,j;
	if(!(n % a)) return false;
	while(!(s & 1))
	{
		s >>= 1;
		r++;
	}
	__int64 k = qpow(a,s,n);
	if(k == 1)
		return true;
	for(j = 0; j < r; j++, k = k * k % n)
		if(k == n-1)
			return true;
	return false;
}

bool isPrime(int n)
{
	int tab[4] = {2,3,5,7};
	for(int i = 0; i < 4; i++)
	{
		if(n == tab[i])
			return true;
		if(!Miller_Rabbin(n,tab[i]))
			return false;
	}
	return true;
}

int main()
{
	int n;
	while(cin>>n)
	{
		int a,ans = 0;
		while(n--)
		{
			cin>>a;
			if(isPrime(a))
				ans++;
		}
		cout<<ans<<endl;
	}
	return 0;
}