1. 程式人生 > >HDU 3549(網路流入門之最大流)

HDU 3549(網路流入門之最大流)

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 10327    Accepted Submission(s): 4866


Problem Description Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
Input The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
Output For each test cases, you should output the maximum flow from source 1 to sink N.
Sample Input 2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
Sample Output Case 1: 1 Case 2: 2
Author HyperHexagon
Source

n個點m條邊,找到1到n使得流量最大。

解題思路;找出所有的增廣路徑,然後再找增廣路徑上的邊,找出最小的流量!!

#include <cstdio>
#include <cmath>
#include <queue>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
int n,m;
int map1[1001][1001];
int pre[1001];
int vis[1001];
int s,t;
bool BFS()
{
    int i,cur;
    queue<int>q;
    memset(pre,0,sizeof(pre));
    memset(vis,0,sizeof(vis));
    vis[s]=1;
    q.push(s);
    while(!q.empty())
    {
        cur=q.front();
        q.pop();
        if(cur==t)
            return 1;
        for(i=1; i<=n; i++)
        {
            if(!vis[i] &&map1[cur][i])
            {
                q.push(i);
                pre[i]=cur;
                vis[i]=1;
            }
        }
    }
    return 0;
}//找增廣路徑
int Max_flow()
{
    int i,ans=0;
    while(1)
    {
        if(!BFS())
            return ans;
        int Min=0x7f7f7f7f;
        for(i=t; i!=s; i=pre[i])
            Min=min(Min,map1[pre[i]][i]);
        for(i=t; i!=s; i=pre[i])
        {
            map1[pre[i]][i]-=Min;
            map1[i][pre[i]]+=Min;
        }
        ans+=Min;
    }
}//找增廣路徑上的最小流量
int main()
{
    int T;
    cin>>T;
    int v,u,c;
    int k=1;
    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(map1,0,sizeof(map1));
        s=1,t=n;
        while(m--)
        {
            scanf("%d%d%d",&u,&v,&c);
            map1[u][v]+=c;
        }
        printf("Case %d: %d\n",k++,Max_flow());
    }
    return 0;
}